Page MenuHomePhabricator

CX2: Add content to the translation paragraph by paragraph
Closed, ResolvedPublic

Description

Content Translation allows editors to translate as much or as little as they want. Editors can add their paragraphs of choice to the translation.

Currently in CX2, the whole article is shown for the translation, as illustrated below:

The expected behaviour is described below:

  • The translation is shown empty.
  • When hovering an empty paragraph in the translation, an "Add translation" placeholder is shown.
  • When hovering an empty paragraph in the translation or the corresponding one in the source text, the source paragraph gets highlighted in yellow.
  • When clicking on an empty target paragraph (or the corresponding source paragraph), the paragraph is added to the translation. Initially, the content added will be a copy of the source paragraph (until machine translation support is added as part of other tickets).

The mockup below illustrates the interaction of adding a paragraph:


Next steps (to be covered by follow-up tickets unless they are trivial to implement as part of this one):

  • Initially when the translation is empty (and the user is not hovering any other paragraph in the translation), the invite to add a new translation will be shown for the first paragraph to communicate the starting point to the user.
  • When clicking on a paragraph that is right after a heading, both the paragraph and the heading will be added to the translation.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 16 2018, 9:35 AM
Pginer-WMF triaged this task as Normal priority.Feb 16 2018, 9:35 AM
Pginer-WMF raised the priority of this task from Normal to High.Mar 2 2018, 12:15 PM
Pginer-WMF updated the task description. (Show Details)Mar 8 2018, 9:53 AM
Pginer-WMF updated the task description. (Show Details)Mar 8 2018, 10:23 AM
Arrbee assigned this task to Nikerabbit.Mar 15 2018, 8:28 AM

Change 420741 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/ContentTranslation@master] Highlight corresponding source section for placeholders

https://gerrit.wikimedia.org/r/420741

Change 420741 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Highlight corresponding source section for placeholders

https://gerrit.wikimedia.org/r/420741

Nikerabbit removed a project: Patch-For-Review.
Petar.petkovic updated the task description. (Show Details)
Arrbee moved this task from QA to Done on the Language-2018-Jan-Mar board.Mar 26 2018, 7:13 AM

I created a follow-up ticket with a couple of additional adjustments related to this: T190907: CX2: Styling adjustments for paragraph highlighting
Everything else works as expected.

Pginer-WMF closed this task as Resolved.Mar 28 2018, 9:13 AM

I'm closing the ticket since the activity can move to the follow-up tickets created (T190907, T190908)