Page MenuHomePhabricator

CTRL+D (forwards delete) on OSX at end of line causes model/view de-sync
Closed, ResolvedPublic1 Estimated Story Points

Description

Reproduced in:

  • OSX 10.13.3 - Safari Version 11.0.3 (13604.5.6)
  • OSX 10.13.3 - Chrome Version 64.0.3282.167

Steps

  1. Edit a new page, I used https://www.mediawiki.org/wiki/User:JHernandez_(WMF)/ve
  2. Type
    1. Hello
    2. <Enter>
    3. world
  3. Go to the end of the first line (<C-p><C-e> for example)
  4. Join the next line <C-d> (maybe Supr if your keyboard has it) and add a <space>
  5. world comes up to the first line
    1. it has a smaller font size for some reason?
    2. Text is in the first line, says Hello world
  6. Go to the end of the line (<C-e> for example)
  7. Type <space>world again
  8. Save
  • Expected
    • The wiki page has the contents Hello world world
    • When editing the joined text has the same font size and behavior
  • Actual
    • The wiki page has the contents:
Hello world world
world

More info

No runtime exceptions were seen in the console.

Published page

https://www.mediawiki.org/wiki/User:JHernandez_(WMF)/ve

In editing screenshot...

... of the weird smaller font size word when joining the line

Other failures

This happened to me while editing a paragraph, and there was a link in the next paragraph, when joining the two paragraphs, and going to the end of the line to continue writing, everything from the small font thing to the end of the line (new things i wrote) disappeared suddenly.

This prompted me to try and reproduce. With the steps above it doesn't delete the text if you write after that weird smaller text, but it did for me in that other ocasion.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 21 2018, 6:06 PM

I can't reproduce this. What keystrokes are you using to get to the end of the line? Is it broken on https://en.wikipedia.beta.wmflabs.org?

Here's a gif with the keys I'm pressing in an overlay.

Could reproduce in mediawiki.org with Safari. Tried on en.wikipedia.beta.wmflabs.org and could reproduce too (tried with Chrome).

In this page: https://en.wikipedia.beta.wmflabs.org/wiki/User:TesterTester the word word2 was only written once, and was duplicated and added at the end by VE after saving the page.

Jdrewniak added a subscriber: Jdrewniak.EditedMar 1 2018, 11:27 AM

Yup I can reproduce this on a Mac using just the "control+d" shortcut at the end of a line.

The issue doesn't happen if I use <fn-delete>.

I've reproduced in Firefox, and moving to the end of the first line with the mouse. The results are even weirder, content gets deleted.

Esanders renamed this task from Duplicate content when saving after joining a line to CTRL+D (forwards delete) on OSX at end of line causes model/view de-sync.Mar 1 2018, 1:40 PM

Change 415590 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Map 'Ctrl+D' on OSX to forwards delete key handler

https://gerrit.wikimedia.org/r/415590

Change 415590 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Map 'Ctrl+D' on OSX to forwards delete key handler

https://gerrit.wikimedia.org/r/415590

Change 415374 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (76774b366)

https://gerrit.wikimedia.org/r/415374

Change 415374 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (f5c88eb30)

https://gerrit.wikimedia.org/r/415374

Deskana closed this task as Resolved.Mar 2 2018, 11:07 AM
Deskana triaged this task as Medium priority.
Deskana set the point value for this task to 1.