Page MenuHomePhabricator

Can not edit "config_wgMetaNamespace" input box as it's readonly
Closed, ResolvedPublic

Description

Behavior
Can't edit "config_wgMetaNamespace" input box in mw-config/index.php?page=Name page.

Reproduce the steps

  1. Follow the installer to Name page (mw-config/index.php?page=Name)
  2. Select radio box - Other (specify)

Step 2 will pop up a text input box, but this box can't be edit, since

<input name="config_wgMetaNamespace" size="30" value="My Wiki" readonly="readonly" class="enabledByOther" id="config_wgMetaNamespace" tabindex="5">

readonly attribute.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 27 2018, 5:48 PM
Aklapper renamed this task from Can not edit "config_wgMetaNamespace" input box to Can not edit "config_wgMetaNamespace" input box as it's readonly.Feb 28 2018, 9:42 AM

Because user can't specify the name of the custom project namespace so I add this blocker.

From looking through the code statically, it explicitly made readonly (in WebInstallerName.php#L76-L79) with the intention that it is also hidden by default. Then, through the enabledByOther functionality, when selecting other, the JavaScript code will make it visible, and remove the readonly attribute (in config.js).

From my point of view, javascript did not remove the readonly attribute. I don't know if other people also have this problem.

Legoktm claimed this task.Apr 6 2018, 11:02 PM

Change 424717 had a related patch set uploaded (by Legoktm; owner: Legoktm):
[mediawiki/core@master] installer: Fix setting a custom $wgMetaNamespace

https://gerrit.wikimedia.org/r/424717

Fomafix closed this task as Resolved.Apr 7 2018, 8:45 AM
Fomafix removed a project: Patch-For-Review.

Change 424717 merged by jenkins-bot:
[mediawiki/core@master] installer: Fix setting a custom $wgMetaNamespace

https://gerrit.wikimedia.org/r/424717