Page MenuHomePhabricator

Remove the "Use global user page" preference from the global user page extension
Closed, ResolvedPublic1 Estimated Story Points

Description

Problem

There's a few issues around GlobalUserPage and GlobalPreferences.

  1. The option "Use global user page" only seems to appear in Special:GlobalPreferences and not Special:Preferences. Why is that so?
  2. When the global preference is enabled and then disabled, it still seems to be enabled in the sense that the global user page still appears.

Solution
  • Remove the "Use global user page" preference from the global user page extension

Event Timeline

Niharika triaged this task as Medium priority.Feb 27 2018, 6:41 PM
Niharika created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 27 2018, 6:41 PM
Keegan added a subscriber: Keegan.Feb 27 2018, 6:55 PM

When the global preference is enabled and then disabled, it still seems to be enabled in the sense that the global user page still appears.

This is confirmed to be true. I think as it is it takes deleting the "home" of the page to remove it from all the wikis, and it can then be recreated locally without the global setting.

I talked with @ashley a few days ago and we talked about just dropping the integration outright, it's mostly been superseded by the __NOGLOBAL_ magic word.

TBolliger renamed this task from Sort out issues around global user page and global preferences to Remove the "Use global user page" preference from the global user page extension.Feb 28 2018, 12:42 AM
TBolliger updated the task description. (Show Details)
TBolliger moved this task from To Be Estimated/Discussed to Estimated on the Community-Tech board.
TBolliger set the point value for this task to 1.
Gryllida added a subscriber: Gryllida.
Gryllida removed a subscriber: Gryllida.

Change 415234 had a related patch set uploaded (by Samwilson; owner: Samwilson):
[mediawiki/extensions/GlobalUserPage@master] Remove GlobalPreferences integration

https://gerrit.wikimedia.org/r/415234

Samwilson moved this task from Ready to In Development on the Community-Tech-Sprint board.

Change 415234 merged by jenkins-bot:
[mediawiki/extensions/GlobalUserPage@master] Remove GlobalPreferences integration

https://gerrit.wikimedia.org/r/415234

Legoktm closed this task as Resolved.Feb 28 2018, 8:27 AM