Timeboxed CommTech QA for Ping from Edit Summary
Closed, ResolvedPublic2 Story Points

Description

Timebox for some of CommTech to hit T32750: [Epic] Ping/notify user when username used in an edit summary with a hammer on Beta Labs for QA. Create any needed Phab tickets.

Number of people: ??
Timebox length: ??

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 27 2018, 11:11 PM
TBolliger renamed this task from CommTech QA for Ping from Edit Summary to Timeboxed CommTech QA for Ping from Edit Summary.Feb 27 2018, 11:41 PM
TBolliger updated the task description. (Show Details)
TBolliger set the point value for this task to 2.
Niharika claimed this task.Mar 1 2018, 9:41 PM
Niharika moved this task from Ready to In Development on the Community-Tech-Sprint board.

This looks pretty good.

  • It pings the first 5 valid users in the edit summary. If you put in 6 users and user #2 has a typo then user 1, 3, 4, 5 and 6 will get pings.
  • I'm feeling a little uneasy about pipe support. Mainly because you cannot see what the wikitext was, nor can you fix it. See this example or this one.
  • Works for anons, as expected.
  • Mentioning people multiple times sends them only one notification, as expected too.
  • People cannot ping themselves, also expected.

I seem to have found a bug. I have three users - [[User:Niharika29]], [[User:Niharika]] and [[User:Niharika2]].

  1. Log in to [[User:Niharika2]] on ruwiki beta.
  2. Open a random article.
  3. Edit article using VE.
  4. Add comment summary - Ping [[User:Niharika]] is a JERK!! And [[User:Niharika29]] is awesome!!. See example.
  5. Go to both of those accounts on enwiki beta. [[User:Niharika]] hasn't received a cross-wiki notification but [[User:Niharika29]] has.

I have a guess at what might be going wrong. It's possible that [[User:Niharika]] account was not attached to ruwiki beta and that was the cause. Once I logged in to that wiki using that account, I started getting cross-wiki notifications. If that's the bug, then it's with Echo.

That's simultaneously a defect and not a defect — hypothetically the user should be able to be pinged (given global accounts) but technically the user account is technically not created at that wiki until the first pageview is made. I strongly believe we should leave it like this, both because this is a Echo issue and will take a lot of effort to dig into and address properly (planning, communication, and dev) but also because if a user has never viewed a wiki they should not receive correspondence from that wiki. They can be contacted at their home wiki or Meta.

TBolliger closed this task as Resolved.Mar 6 2018, 12:20 AM

Forgot to add — great work, thanks Niharika! (although it was somewhat disturbing to see your example summaries 😬)