Page MenuHomePhabricator

[Regression pre-wmf.23] Weird wikitext formatting observed while editing with NWE when syntax highlighting is on
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Open NWE
  2. Enable the syntax highlighting
  3. Now add a page title

Observe that the closing ("==") tags are appearing randomly in the middle of the next line if there is more content after that line. If not, all the "=" tags are appearing at the beginning.

On Beta Cluster:


On test2:


Details

Related Gerrit Patches:
mediawiki/extensions/CodeMirror : masterVE: Use different approach for transparent text issue

Event Timeline

Ryasmeen created this task.Feb 28 2018, 1:27 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 28 2018, 1:27 AM

Same issue occurs for the following cases:

  1. Adding text with formatting such as "bold" .
  2. Inserting table .
  3. Inserting comment.
Esanders triaged this task as High priority.
Esanders edited projects, added VisualEditor (Current work); removed VisualEditor.

Regression caused by fix for T185184

Change 415273 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/CodeMirror@master] VE: Use different approach for transparent text issue

https://gerrit.wikimedia.org/r/415273

Restricted Application added a project: Community-Tech. · View Herald TranscriptFeb 28 2018, 8:53 PM

Change 415273 merged by jenkins-bot:
[mediawiki/extensions/CodeMirror@master] VE: Use different approach for transparent text issue

https://gerrit.wikimedia.org/r/415273

Deskana closed this task as Resolved.Mar 7 2018, 5:13 PM
Deskana set the point value for this task to 1.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 7 2018, 5:13 PM
TBolliger moved this task from Untriaged to Archive on the Community-Tech board.Mar 7 2018, 5:18 PM