Page MenuHomePhabricator

Page previews text and formulas cut off on arwiki
Closed, ResolvedPublic

Description

Background

Reported while testing html summaries

Steps to reproduce

  1. Go to https://ar.wikipedia.org/wiki/%D9%87%D9%86%D8%AF%D8%B3%D8%A9_%D8%B1%D9%8A%D8%A7%D8%B6%D9%8A%D8%A9
  2. Hover over والمساحات

Observed - text is cutoff

Note: seeing this in many other places on arwiki:



Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 28 2018, 3:45 PM
ovasileva triaged this task as High priority.Feb 28 2018, 3:45 PM
ovasileva added a project: Page-Previews.

It looks like the popups code defines a maximum height for the popup text to 140px. That height is probably enough for most languages, but I guess not Arabic.


We
a. could adjust that height, just give it like, 200px or something bigger than it is now.
b. get rid of the max-height and be certain that the text won't cut off, but risk having very long popups.

at least it looks good on Windows

ovasileva added subscribers: ABorbaWMF, Jdlrobson.

Seems @Jdlrobson got this fixed: T182319#4012465! Pulling into sprint for QA. @ABorbaWMF - could you take a look across a couple of browsers? I tested a bit and it looks good to me.

ovasileva closed this task as Resolved.Mar 1 2018, 6:06 PM

looks good!