Add monolingual language code sjd
Closed, ResolvedPublic

Description

Please add the language code sjd to the list of language codes supported for monolingual text values.

Usage example: I have several works to be uploaded (T184436) that are in Kildin Sami.

Native name: Кӣллт са̄мь кӣлл
English name: Kildin Sami
Language item: https://www.wikidata.org/wiki/Q33656

Change 415496 had a related patch set uploaded (by Jon Harald Søby; owner: Jon Harald Søby):
[mediawiki/extensions/Wikibase@master] Add monolingual codes sjd, smn, sms

https://gerrit.wikimedia.org/r/415496

jhsoby-WMNO moved this task from incoming to ready to go on the Wikidata board.Mar 1 2018, 8:57 AM

Change 415496 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Add monolingual codes sjd, sju, smn, sms

https://gerrit.wikimedia.org/r/415496

jeblad added a subscriber: jeblad.EditedMar 1 2018, 7:24 PM

There is a bunch of missing codes, it would be nice if they could all be fixed.

Se for example T74590: [Bug] Monolingual code is missing for Kvensk (fkv), Romani (rom) and Scandoromani (rmg-variant)

The names are Norwegian

Akkala-, Ter- and Kildin Sami Language uses Cyrillic script, Skolt Sami is still in use in Russia wit Cyrillic script. Skolt Sami in Finland is written with Latin script. All other uses Latin script.

jeblad added a comment.Mar 1 2018, 7:27 PM

Note also that adding codes that isn't recognized by CLDR can create problems. That is, these codes should be reported upstream. https://translatewiki.net/wiki/CLDR

@jeblad After these patches, the only missing Sami languages in Wikidata are Akkala Sami, Kemi Sami and Ter Sami. All are dead (or almost dead) with little or no literature. In the Sami bibliography I'm working on uploading, there are no texts in any of these languages. So I don't think it's necessary to add them yet, at least not until we have good use-cases where it is necessary to have these codes for monolingual properties.

Also, what kind of problems re. CLDR? There are already plenty of languages enabled for monolingual text in Wikidata that are not supported in CLDR, but I haven't heard of any problems because of that.

jhsoby-WMNO closed this task as Resolved.Mar 2 2018, 10:46 AM
jhsoby-WMNO moved this task from In progress to Done on the WMNO-Northern-Sami board.

@jhsoby-WMNO The issue is T124758 for the ones not in CLDR.

jeblad added a comment.Mar 2 2018, 3:34 PM

@jhsoby-WMNO To make reuse a viable option language codes must be according to known good standards. Consider the problems with no/nb/nn language codes.

Also if there are any open questions it is not wise to close the task as further discussions will then be more or less dead. Users leave the task and some even unsubscribe automatically.

jeblad removed a subscriber: jeblad.Mar 2 2018, 3:34 PM
jhsoby-WMNO reopened this task as Open.EditedMar 6 2018, 12:46 PM
jhsoby-WMNO added a subscriber: jeblad.

@jeblad You're right, sorry, my bad, so re-opened for now. You have a point, but I think it is a wider issue than what's fit for just this task for a single language code. This is not the first and likely not the last monolingual language code that isn't in CLDR. I think this should preferrably be discussed in a higher-level task like T144272 or T124758, or perhaps a task of its own. What do you think?

Lydia_Pintscher closed this task as Resolved.Mar 6 2018, 12:57 PM

The fix for that is discussed in T124758.