Page MenuHomePhabricator

External link icon appearing twice
Closed, ResolvedPublic8 Story Points

Description

Steps to reproduce:

  1. Open VE
  2. Insert an external link
  3. Save the page
  4. Reopen the page

Two external link icons are appearing next to the link

Details

Related Gerrit Patches:

Event Timeline

Ryasmeen created this task.Mar 1 2018, 7:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 1 2018, 7:07 PM
Deskana changed the task status from Open to Stalled.Mar 2 2018, 11:09 AM
Deskana triaged this task as Medium priority.

I can't reproduce this in my sandbox on the English Wikipedia. How are you inserting the link, and what does it look like before and after you save?

Here are the screenshots:

Before saving:

After saving:

Ryasmeen changed the task status from Stalled to Open.Mar 2 2018, 10:49 PM

@Deskana
On enwiki (wmf.1) on your sandbox page (User:username/sandbox)

  • click the link icon and switch to the External tab in the Link inspector
  • type http://www.google.com - click Insert - the display is correct
  • click Publish to save your changes - the display will be correct
  • click to open VE - double icons will be displayed:

Note: the external links can be added just by typing [ in VE to switch to insert link mode. Interwiki and internal links are ok.

Esanders added a subscriber: Esanders.EditedMay 31 2018, 1:49 PM

This is due to a change in the Parsoid DOM spec (v1.6) which adds 'external' classes (T58756). We need to update our CE code.

Esanders claimed this task.May 31 2018, 1:49 PM
Esanders raised the priority of this task from Medium to High.
Esanders edited projects, added VisualEditor (Current work); removed VisualEditor.
Esanders set the point value for this task to 8.

Change 436544 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Fix parsing of external links, now Parsoid adds 'external' classes

https://gerrit.wikimedia.org/r/436544

Change 436544 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Fix parsing of external links, now Parsoid adds 'external' classes

https://gerrit.wikimedia.org/r/436544

Deskana closed this task as Resolved.Jun 11 2018, 3:05 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJun 11 2018, 3:05 PM