Page MenuHomePhabricator

Section editing broken when page uses translatable section title
Closed, InvalidPublic

Description

Steps to reproduce:

  1. enable new wikitext editor (I used it with the syntax highlight beta option, but I doubt it matters)
  2. visit https://meta.wikimedia.org/wiki/Mass_account_creation
  3. click on the edit link next to "Becoming an account creator"

You'll end up editing an entirely different section.

Event Timeline

Tgr created this task.Mar 1 2018, 9:49 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptMar 1 2018, 9:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Tgr renamed this task from Section editing broken in new wikitext editor when page uses translatable section title to Section editing broken when page uses translatable section title.Mar 1 2018, 9:51 PM
Tgr added a comment.Mar 1 2018, 9:54 PM

Not actually related to new wikitext editor. Maybe a duplicate of T58838: Section editing: Off-by-one error and "empty translation unit" (although the section is off by more than one, and the bug referenced there seems fixed already), or T134194: Fake sections in translate tags don't work when you click their section edit link (although the example mentioned there seems to work fine).

Nikerabbit added a subscriber: Nikerabbit.EditedMar 2 2018, 7:27 AM

I fixed it for you. The page was not marked according to the best practices which ensure that section editing works. There are still weird things like one section being "text\n</div>\nmore text".

Nikerabbit closed this task as Invalid.Jun 26 2018, 1:55 PM

I'm closing this task. The recommend way to add markup is documented in the documentation page, and this issue is unlikely to get fixed until there is full VE-no-markup support for translatable pages.