Page MenuHomePhabricator

WMCZ want to use its own mail system instead of OTRS queue wm-cz@wikimedia.org
Closed, ResolvedPublic

Description

Hello,

Wikimedia Czech republic (WMCZ) want to use its own mail system for generic email address instead of OTRS queue wm-cz@wikimedia.org. On behalf of WMCZ I think that the following tasks should be performed:

  1. Redirect wm-cz@wikimedia.org to info@wikimedia.cz and delete the OTRS queue
  2. If easy enough: Export all existing tickets and send the archive to me so we can import them

This request is approved by @Vojtech.dostal, the chairman. He will approve personally by adding a comment.

Thank you in advance,
Martin Urbanec
system administrator
Wikimedia Czech republic

Event Timeline

Urbanecm created this task.Mar 2 2018, 5:06 PM
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptMar 2 2018, 5:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Yes I confirm that this is approved and thanks for processing the request, @Urbanecm

Urbanecm removed subscribers: OTRS, Office-IT.
Scoopfinder added a subscriber: Scoopfinder.EditedMar 2 2018, 5:09 PM

As this been cleared by WMF Legal ? There might be consequences to mix WMF domain and chapter ones like this, nah?

wm-cz is not a community queue, it has always been a chapter queue.
community uses info.cs :-)

Well... The queue already exist and WMCZ would like WMF to drop it and use own systems (wikimedia.cz is entriely in our control and except the name it has nothing to do with WMF). I guess that legal do not need to approve just dropping the queue and aliasing to maintain the availability of the old address so users who know it will be able to deliver mails to us.

Also make it a lot harder for cross-wiki postings (i.e. something comes into info-en, now instead of just "move to info-cz" I have to actually forward the whole damn thing).

Nope you just move it to @info-cs @Primefac

Keegan added a subscriber: Keegan.Mar 2 2018, 5:14 PM

<OTRS admin hat>

We can free up wm-cz@ from OTRS, but I believe you will need someone else to alias the address to the proper place. I will try to dig up who would be responsible for doing that.

So, "moving" it to the queue would still forward it to the proper location? How would we then track it if it's being forwarded to their private servers?

Keegan added a comment.Mar 2 2018, 5:18 PM

So, "moving" it to the queue would still forward it to the proper location? How would we then track it if it's being forwarded to their private servers?

Slow down folks, some of y'all are conflating two things...

OTRS has two main functions: hosting community queues, and hosting chapter queues.

Hosting chapter queues is a service that OTRS provides to chapters. OTRS admins and OTRS volunteers do not support these queues, the chapters are responsible. If a chapter wants to take its email off of OTRS, that is fine.

You can and will still move emails to info-cs just as you do now, there will be no discernible change to community workflow.

Oh, well... carry on then.

Understood @Keegan, but what about the domain name ? Can @wikimedia.org emails be redirected directly to another address? Doesn't it raise some issues in regards to the WMF privacy policy for example?

My first question still stands: are there legal implications behind this and, if yes, do they block this request?

  1. If easy enough: Export all existing tickets and send the archive to me so we can import them

@Jalexander Not sure we would be able to do this, even if it's technically possible (which I'm unsure). Thoughts from SuSa?

Urbanecm added a comment.EditedMar 2 2018, 5:35 PM

@Scoopfinder This should be at least technically possible, see T160400 as an example of an accepted request.

Keegan added a comment.Mar 2 2018, 5:41 PM

Was sorting out who at the WMF "owns" this alias process since it's not for internal staff, nor for mailing lists. I've been told to tag Operations and someone will look at it next week.

Keegan edited projects, added Operations; removed Office-IT.Mar 2 2018, 5:42 PM

Great, thanks!

Dzahn added a subscriber: Dzahn.Mar 2 2018, 6:10 PM

Please see the details in the linked ticket T160400. It was ultimately solved by OIT (eross) by adding the alias on the Google side. We would like to add all new aliases there and move existing aliases over (as was done for many in T122144). So this isn't really an Operations thing anymore nowadays.

Keegan edited projects, added Office-IT; removed Operations.Mar 2 2018, 6:38 PM
Keegan removed a subscriber: Vojtech.dostal.

Please see the details in the linked ticket T160400. It was ultimately solved by OIT (eross) by adding the alias on the Google side. We would like to add all new aliases there and move existing aliases over (as was done for many in T122144). So this isn't really an Operations thing anymore nowadays.

Great, thank you Daniel.

Urbanecm triaged this task as Normal priority.Mar 10 2018, 3:34 PM

Hey all, what's the status of this request?

Dzahn added a comment.Mar 22 2018, 6:56 PM

@Urbanecm If you don't get a reply here on Phab, try contacting techsupport@wikimedia.org or Emerauld directly https://wikimediafoundation.org/wiki/User:ERoss_(WMF) and say you want the same thing that was done on T160400#3111002 and the how-to should be T160400#3110170.

Dzahn added a subscriber: eross.Mar 22 2018, 6:57 PM

@eross ^ Could you do that for Urbanecm like you did before for another wikimedia.cz address ?

I wrote to @eross already. No reply, through. But thank you.

eross added a comment.Mar 22 2018, 7:10 PM

Hi All,

Sure thing, I can work on this. For future reference It's best to send a ticket to techsupport@ .

Best,
Emerauld

eross added a comment.Mar 23 2018, 8:18 PM

Sent a test email, please let me know if the routing is working properly.

@eross Thanks, working.

To OTRS admins: Is it possible to export OTRS queue, send it to me and then delete it? Thank you.

Keegan added a subscriber: Krd.Mar 25 2018, 9:55 PM

@Urbanecm I believe it is possible for us to set up a script that will pull all the tickets from wm-cz into a .csv file for export. I do not have the technical skills to do this myself, however.

@Krd is this something that you might know how to do, or do you know of another that could?

Krd added a subscriber: akosiaris.Mar 26 2018, 7:18 AM

Straight away I don't know if and how this could be done, this would require some research, ad I think we need root support for this. @akosiaris could be the person to ask.

Anyway, I won't do anything without explicit clearance from WMF legal.

Well... when I was talking about export I thought about something like eml/mbox file containing the queue like inbox. As it seems it won't be easy, I would like to remind the task's description, quoted below.

If easy enough: Export all existing tickets and send the archive to me so we can import them

Also I really don't know why Legal's involvment should be required, if we talk about confidentiality, I signed the Confidentiality agreement for nonpublic information (verify). But again, if this isn't "click at export button in the admin interface", let's make this resolved as the redirect itself is working (thank you @eross).

Cheers,
Martin

Krd added a comment.Mar 26 2018, 7:50 AM

Negative. If an e-mail address has been redirected, OTRS admins shall to be informed accordingly to remove the e-mail address from OTRS and close the related queues, in order to avoid tickets being moved to a queue that is no longer read, or e-mails getting CCed to an address that is still considered internal and never sent out.

Then, feel free to close the queue. E-mails sent to wm-cz@wikimedia.org never get to the queue. Instead, they are directed to info@wikimedia.cz.

Krd added a comment.Mar 26 2018, 8:11 AM

Done accordingly.

Well... when I was talking about export I thought about something like eml/mbox file containing the queue like inbox. As it seems it won't be easy, I would like to remind the task's description, quoted below.

If easy enough: Export all existing tickets and send the archive to me so we can import them

But again, if this isn't "click at export button in the admin interface", let's make this resolved as the redirect itself is working (thank you @eross).

I can confirm it's not as easy as "click an export button in the admin interface". Just a thing does not exist. On the contrary extra software needs to be installed (https://github.com/OTRS/ImportExport). The above is not tested in our installation and it would probably require a considerable amount of time to test, install and learn to use. So, since the exporting is marked as "if easy enough", I am inclined to avoid it. Thanks.

eross added a comment.Mar 26 2018, 8:17 PM

@eross Thanks, working.
To OTRS admins: Is it possible to export OTRS queue, send it to me and then delete it? Thank you.

Awesome! Glad I could help.

Urbanecm closed this task as Resolved.Mar 26 2018, 8:18 PM
Urbanecm assigned this task to eross.

Withdrawing the export request, queue should be deleted (per @Krd), redirect's working (per @eross), closing as resolved and assigning to @eross.