Page MenuHomePhabricator

VE adding extra parameters
Closed, InvalidPublic

Description

VE appears to add extra parameters to infoboxes that a user has not requested / added. Here is an example https://en.wikipedia.org/w/index.php?title=Hiatal_hernia&type=revision&diff=828702902&oldid=828702735&diffmode=source

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 4 2018, 10:53 AM

Hi @Doc_James, thanks for taking the time to report this! What are steps to reproduce the problem? Was "Search / Replace [all]" involved here?

Restricted Application added a project: VisualEditor. · View Herald TranscriptMar 4 2018, 1:39 PM
Esanders added a subscriber: Esanders.

It looks like all 'recommended' fields get added by the template editor. I assume this is intended behaviour...

Doc_James added a comment.EditedMar 5 2018, 9:42 AM

Okay so using VE I added the term "testing" in this edit https://en.wikipedia.org/w/index.php?title=Hiatal_hernia&type=revision&diff=828884102&oldid=828724269&diffmode=source

The VE tool than went ahead and added "synonym" duplicating the "synonyms" parameter" and "speciality" duplicating the "field" parameter. Either synonym or synonyms is accepted as the same in this infobox. Same with field and speciality.

I did not mean to add these empty parameters. Unless someone adds text into one of them they should I hope not be added. Is it possible to tern of "recommended" for fields in the "infobox medical condition (new)"

Deskana closed this task as Invalid.Mar 6 2018, 1:39 PM
Deskana added a subscriber: Deskana.

When adding templates in the visual editor, blank parameters are added when they are marked as "suggested" in that template's data. This is intended functionality. If users don't want those parameters added, they should not be marked as suggested in the template data. Doc James has now done that for this specific template.