Page MenuHomePhabricator

Fix CX2 test instance publishing
Closed, ResolvedPublic

Description

Find root cause of CX2 publishing failure and fix it.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 8 2018, 9:18 AM

Following error is observed in console when trying to publish:

error:
    *: "See http://cx2-testing.wmflabs.org/api.php for API usage. Subscribe to the mediawiki-api-announce mailing list at <https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce> for notice of API deprecations and breaking changes."
    code: "docserver"
    info: "Error converting HTML to wikitext: docserver-http: HTTP 500"

It's trying to connect restbase on localhost for some reason.

Change 417219 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/ContentTranslation@master] Improve restbase error reporting

https://gerrit.wikimedia.org/r/417219

Change 417219 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Improve restbase error reporting

https://gerrit.wikimedia.org/r/417219

Etonkovidova closed this task as Resolved.Mar 12 2018, 9:17 AM
Etonkovidova added a subscriber: Etonkovidova.

Checked Publish functionality in cx2 - all seems to be working.

Petar.petkovic moved this task from Backlog to Done on the ContentTranslation-Deployments board.
Petar.petkovic moved this task from QA to Done on the Language-2018-Jan-Mar board.

It's trying to connect restbase on localhost for some reason.

We changed it to not use the local parsoid.

Pginer-WMF triaged this task as Normal priority.Mar 13 2018, 7:17 AM