Page MenuHomePhabricator

Remove deprecated function Title::getTitleInvalidRegex()
Closed, ResolvedPublic

Description

This function has deprecated since MediaWiki 1.25.

The Alternative is MediaWikiTitleCodec::getTitleInvalidRegex()

One patch has already Upload by @Legoktm

https://gerrit.wikimedia.org/r/#/c/417780/

Event Timeline

Restricted Application added a project: User-Jayprakash12345. · View Herald TranscriptMar 9 2018, 7:40 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 418029 had a related patch set (by Jayprakash12345) published:
[mediawiki/extensions/LiquidThreads@master] Remove deprecated function Title::getTitleInvalidRegex()

https://gerrit.wikimedia.org/r/418029

Change 418032 had a related patch set (by Jayprakash12345) published:
[mediawiki/core@master] Remove deprecated function Title::getTitleInvalidRegex()

https://gerrit.wikimedia.org/r/418032

Change 418032 abandoned by Legoktm:
Remove deprecated function Title::getTitleInvalidRegex()

Reason:
This is a duplicate of James's patch: Change-Id: I8b8dd744c4c2ca5a13c89701b44013ddda785f3b

https://gerrit.wikimedia.org/r/418032

Change 417780 had a related patch set uploaded (by Umherirrender; owner: Legoktm):
[mediawiki/extensions/UserGroups@master] Avoid deprecated Title::getTitleInvalidRegex()

https://gerrit.wikimedia.org/r/417780

Change 417780 merged by jenkins-bot:
[mediawiki/extensions/UserGroups@master] Avoid deprecated Title::getTitleInvalidRegex()

https://gerrit.wikimedia.org/r/417780

Change 418029 merged by jenkins-bot:
[mediawiki/extensions/LiquidThreads@master] Don't call deprecated function Title::getTitleInvalidRegex()

https://gerrit.wikimedia.org/r/418029

Umherirrender closed this task as Resolved.Apr 20 2018, 8:01 PM
Umherirrender triaged this task as Normal priority.
Umherirrender added a subscriber: Umherirrender.