Page MenuHomePhabricator

deployment-tin: scripts taking a whole lot more of time to complete
Closed, ResolvedPublic

Description

As reported at https://www.mediawiki.org/wiki/Topic:U8v0yb8yu4jfysn6 I'm experiencing very slow speed on deployment-tin when running some scripts that some weeks ago took half the time to complete. I do not know why or what may be the cause. Thank you.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 13 2018, 10:23 PM
Krinkle closed this task as Resolved.Jul 6 2018, 11:46 PM
Krinkle claimed this task.
Krinkle added a subscriber: Krinkle.

This is most likely due to the switching of mwscript from PHP5 to HHVM.

While HHVM tends to be significantly faster than PHP5 for something like a web server (which runs for a long time, and does the same thing many times), for maintenance scripts it's essentially a "new" HHVM server each time, which takes time to start up and optimise all the code - which is not very useful for scripts that only take a few seconds to run.

However, while this slowdown is unfortunate, it is unavoidable for the time being because PHP 5 is too old and no longer supported by MediaWiki.

Related:

The effort to optimise mwscript to use HHVM in a more efficient way (for example, to disable its JIT optimiser, and other ideas) is already tracked at T191921.

Also, we found at T191921 that the main reason for the slowdown does not seem to be the JIT initialisation, but rather something unknown that seems to be specific to Debian Jessie. The same configuration of HHVM on newer Debian Stretch hosts performed much faster.

In the medium-term, this will be obsolete once we migrate to PHP 7, tracked at T176370.

Marking as resolved, given it's already much better on the Stretch hosts, but could also mark as duplicate of T191921.