Deploy GlobalPrefs on production
Closed, ResolvedPublic3 Story Points

Description

This includes:

  • Running the create table script on s7. See T184666#4053182
  • Deploying the extension itself

Related Objects

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 420948 had a related patch set uploaded (by Niharika29; owner: Niharika29):
[operations/mediawiki-config@master] Deploy GlobalPrefs to all production wikis

https://gerrit.wikimedia.org/r/420948

Change 421185 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[operations/mediawiki-config@master] Deploy GlobalPreferences everywhere but Wikipedia

https://gerrit.wikimedia.org/r/421185

Change 421185 merged by jenkins-bot:
[operations/mediawiki-config@master] Deploy GlobalPreferences everywhere but Wikipedia

https://gerrit.wikimedia.org/r/421185

Update: after 14 minutes on non-WP wikis, I had to revert because of shenanigans in the logs that were submitted as 2 above bugs. Leaving the extension enabled on test wikis for now as it hadn't caused any problems there so far.

MaxSem added a comment.EditedMar 21 2018, 10:55 PM

Noticeable increase of traffic on a s7 DB server corresponding to the time GP was enabled:

15:18 <+logmsgbot> !log maxsem@tin Synchronized wmf-config/InitialiseSettings.php: https://gerrit.wikimedia.org/r/#/c/421185/ (duration: 01m 15s)
15:32 <+logmsgbot> !log maxsem@tin Synchronized wmf-config/InitialiseSettings.php: Revert global prefs (duration: 01m 15s)

Change 421331 had a related patch set uploaded (by Zfilipin; owner: Zfilipin):
[operations/mediawiki-config@master] Revert "Redeploy GlobalPreferences to test wikis and mw.org"

https://gerrit.wikimedia.org/r/421331

I have asked for that ^ revert, as it looks like a "cheap" revert, and the spike is important enough to see if that change is causing it.

Change 421331 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Redeploy GlobalPreferences to test wikis and mw.org"

https://gerrit.wikimedia.org/r/421331

Mentioned in SAL (#wikimedia-operations) [2018-03-22T16:28:18Z] <zfilipin@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:421331|Revert "Redeploy GlobalPreferences to test wikis and mw.org" (T189806)]] (duration: 01m 14s)

MaxSem updated the task description. (Show Details)Mar 22 2018, 8:46 PM

Please let us know when this is ready for Tech/News announcement, by moving it 1 column to the right in the User-notice workboard. Thanks! (p.s. here's the previous wording draft, removed for now, in case re-usable.)

Stryn added a subscriber: Stryn.Mar 22 2018, 9:18 PM
Nirmos added a subscriber: Nirmos.Apr 16 2018, 8:47 AM

Mentioned in SAL (#wikimedia-operations) [2018-04-25T22:21:54Z] <samwilson@tin> Synchronized wmf-config/InitialiseSettings.php: Deploy GlobalPreferences T189806 (duration: 01m 18s)

TBolliger moved this task from Blocked to Backlog on the Community-Tech board.May 18 2018, 12:13 PM

Change 434368 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[operations/mediawiki-config@master] Enable GlobalPreferences on non-Wikipedias

https://gerrit.wikimedia.org/r/434368

Change 434368 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable GlobalPreferences on non-Wikipedias

https://gerrit.wikimedia.org/r/434368

We're live everywhere but Wikipedias.

Guycn2 added a subscriber: Guycn2.May 29 2018, 9:02 PM
Keegan added a subscriber: Keegan.Jun 4 2018, 11:03 PM

We're live everywhere but Wikipedias.

This is still the status. There are some more bugs to be fixed before full release, should been in the near future but not in this sprint.

Keegan triaged this task as Normal priority.Jun 4 2018, 11:04 PM
Keegan raised the priority of this task from Normal to Needs Triage.

didn't mean to set priority

TheDJ added a subscriber: TheDJ.Jun 14 2018, 7:40 AM

Not sure where this project is, but I just noticed that on test.wikipedia.org, I see the gadgets from test2.wikipedia.org

Definition for test.wp: https://test.wikipedia.org/wiki/MediaWiki:Gadgets-definition

Does not match with the gadgets shown on test.wp
https://test.wikipedia.org/wiki/Special:Gadgets
https://test.wikipedia.org/wiki/Special:Preferences#mw-prefsection-gadgets

which instead reflects what seems to be https://test2.wikipedia.org/wiki/MediaWiki:Gadgets-definition

Can be a configuration problem or something, or it's an actual software problem, not sure.

Hi @TheDJ. The problem does not seem related to GlobalPreferences because GP does not globalize gadgets. GP is deployed on all non-Wikipedia wikis. You can access it by going to https://test.wikipedia.org/wiki/Special:GlobalPreferences (link under Special:Preferences > User profile).

Just to confirm:

mysql:wikiadmin@db1079 [centralauth]> select count(*) from global_preferences where gp_property like 'gadget%';
+----------+
| count(*) |
+----------+
|        0 |
+----------+
1 row in set (0.00 sec)

Current stats:
Total number of users with a global preference set: 403
Number of preferences set using GP so far: 9835

Change 444652 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[operations/mediawiki-config@master] Deploy GlobalPreferences to the rest of SUL wikis

https://gerrit.wikimedia.org/r/444652

Change 444652 merged by jenkins-bot:
[operations/mediawiki-config@master] Deploy GlobalPreferences to the rest of SUL wikis

https://gerrit.wikimedia.org/r/444652

Niharika updated the task description. (Show Details)Jul 10 2018, 3:22 AM
Niharika closed this task as Resolved.
Niharika moved this task from Backlog to Archive on the Community-Tech board.
Niharika claimed this task.
Niharika reassigned this task from Niharika to MaxSem.

This was deployed earlier today.

Maybe it's best to wait for Thu eve, when T195288 will gone.

I do not get emails on Structured Discussions updates, despite I marked this as global. Can it be a problem of GlobalPreferences that does not recognize notification preferences?

I do not get emails on Structured Discussions updates, despite I marked this as global. Can it be a problem of GlobalPreferences that does not recognize notification preferences?

Can you mention exactly which preference are you talking about? How did you set it? A screenshot of the preference on Special:Preferences and Special:GlobalPreferences will be very useful.

I do not get emails on Structured Discussions updates, despite I marked this as global. Can it be a problem of GlobalPreferences that does not recognize notification preferences?

Can you mention exactly which preference are you talking about? How did you set it? A screenshot of the preference on Special:Preferences and Special:GlobalPreferences will be very useful.

Thank you for your attention. Here is my local (he)wiki Global Preferences page. I set them two days ago for this specific preference. I'm talking about the third line, Structured Discussion in Notify me about these events.


Here is catalanian Global Preferences page.

Here is catalanian Preferences page.

And still, I did not get about 10 emails about the topic. I did not get an email about the notifying me in the discussion too, but it happens sometimes.

@IKhitron To confirm - did this only happen on cawiki or also on other wikis?

I do not know. I'll check next time I get a notification from SD on another wiki, and tell you.

@IKhitron This might be related to T195288: Local exception for notifications does not work which is going to be fixed everywhere by tomorrow. Let me know if this happens again. I'll be doing some tests myself as well.

I'm on group one, but maybe. I will, thanks.

Quiddity removed a subscriber: Quiddity.Jul 12 2018, 4:56 PM

Change 420948 abandoned by Niharika29:
Deploy GlobalPrefs to all production wikis

Reason:
Was superseded by another patch.

https://gerrit.wikimedia.org/r/420948

Well, @Niharika, it happened today again, on the same page. And also, I get a notification just now from mediawiki.org - there the preference was always local.

Well, @Niharika, it happened today again, on the same page. And also, I get a notification just now from mediawiki.org - there the preference was always local.

Okay. Can you open a new ticket for this issue? Don't make it a sub-ticket of this one, only put it on MediaWiki-extensions-GlobalPreferences. Let's discuss there.

IKhitron added a comment.EditedThu, Aug 9, 1:11 PM

Hi. Pay attention, that after the deployment many local preferences where restored to default, so the user values were lost. Looks like in notifications tab only, but maybe I just did not see it in others.

Hi. Pay attention, that after the deployment many local preferences where restored todefault, so the user values were lost. Looks like in notifications tab only, but maybe I just did not see it in others.

Thanks for bringing it up @IKhitron. The issue is known and is being tracked in T201340: Local notification settings stuck at latest global preference. The problem only occurs for the notifications input only and not for anything else. The exact cause and behavior is yet unknown. @MaxSem is investigating it.