Page MenuHomePhabricator

Special:Nearby regression in #/page/{title} route
Closed, ResolvedPublic

Description

Special:Nearby is supposed to show places nearby the given argument, if given any in the URL, for example https://sv.wikipedia.org/wiki/Special:N%C3%A4ra#/page/Oslo

Since recently, there is now a race condition so that sometimes, you'll see places near the given article, and sometimes you'll see articles near yourself.

I can see that there has been work in T125820 lately, so I'm holding @pmiazga, @Jdlrobson and @Niedzielski guilty until proven innocent =)

Event Timeline

Nirmos created this task.Mar 15 2018, 9:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 15 2018, 9:07 PM

The page parameter is undocumented and not officially supported :)

Could you elaborate on what you mean by a race condition?
Are you able to replicate the same issue on https://reading-web-staging.wmflabs.org/wiki/Special:Nearby ? We've made a lot of changes to this page, so it's possible this is no longer an issue.

Jdlrobson renamed this task from Special:Nearby regression to Special:Nearby regression in #/page/{title} route.Mar 15 2018, 9:27 PM
Jdlrobson triaged this task as Low priority.
Jdlrobson moved this task from To Triage to Needs Analysis on the Readers-Web-Backlog board.

Could you elaborate on what you mean by a race condition?

When I load https://sv.wikipedia.org/wiki/Special:N%C3%A4ra#/page/Oslo I sometimes get articles near Oslo, and sometimes articles near myself.

Are you able to replicate the same issue on https://reading-web-staging.wmflabs.org/wiki/Special:Nearby ?

Hard to say. I'm having trouble connecting to that site (it's really slow for me). Also, there is, as far as I can see, only one article there with coordinates (Spain).

Hard to say. I'm having trouble connecting to that site (it's really slow for me). Also, there is, as far as I can see, only one article there with coordinates (Spain).

Nearby there will uses English Wikipedia production api so should be pretty complete data-wise :). The important thing to note is that now in the new version you need to click a button to seek location.

No, I can't reproduce the issue on https://reading-web-staging.wmflabs.org/wiki/Special:Nearby#/page/Spain. Thanks! I suppose this can be closed as resolved. Do you know when this will be deployed to WMF wikis?

@Nirmos on next week's train. Should be out between Tuesday and Thursday!

There has been some erratic behaviour of this feature for Wikidata as well lately, e.g.
https://www.wikidata.org/wiki/Special:Nearby#/page/Q16896007
sometimes goes to where it would be expected, and sometimes to where the user is.

cc @Fnielsen

Nirmos closed this task as Resolved.Mar 29 2018, 11:48 AM
Nirmos claimed this task.

I can no longer reproduce this problem, so I'm marking this as resolved.

It seems to work for me too now, while I had the problem before.