Page MenuHomePhabricator

PHP Fatal Error: Invalid operand type was used: cannot perform this operation with arrays
Closed, ResolvedPublic

Description

2018 - 03 - 15 23: 49: 15[WqsGewpAICsAAC - WEagAAABW] mw1322 enwiki 1.31 .0 - wmf .25 fatal ERROR: [f95013bc] PHP Fatal Error: Invalid operand type was used: cannot perform this operation with arrays {
    "fatal_exception": {
        "class": "ErrorException",
        "message": "PHP Fatal Error: Invalid operand type was used: cannot perform this operation with arrays",
        "code": 16777217,
        "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/specials/pagers/NewFilesPager.php",
        "line": 121,
        "trace": [{
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/specials/pagers/NewFilesPager.php",
            "line": 121
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/pager/IndexPager.php",
            "line": 381,
            "function": "getQueryInfo",
            "class": "NewFilesPager",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/pager/RangeChronologicalPager.php",
            "line": 106,
            "function": "buildQueryInfo",
            "class": "IndexPager",
            "type": "->",
            "args": ["string", "integer", "boolean"]
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/pager/IndexPager.php",
            "line": 366,
            "function": "buildQueryInfo",
            "class": "RangeChronologicalPager",
            "type": "->",
            "args": ["string", "integer", "boolean"]
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/pager/IndexPager.php",
            "line": 225,
            "function": "reallyDoQuery",
            "class": "IndexPager",
            "type": "->",
            "args": ["string", "integer", "boolean"]
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/pager/IndexPager.php",
            "line": 422,
            "function": "doQuery",
            "class": "IndexPager",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/specials/SpecialNewimages.php",
            "line": 106,
            "function": "getBody",
            "class": "IndexPager",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/specialpage/SpecialPage.php",
            "line": 522,
            "function": "execute",
            "class": "SpecialNewFiles",
            "type": "->",
            "args": ["NULL"]
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/specialpage/SpecialPageFactory.php",
            "line": 579,
            "function": "run",
            "class": "SpecialPage",
            "type": "->",
            "args": ["NULL"]
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/MediaWiki.php",
            "line": 288,
            "function": "executePath",
            "class": "SpecialPageFactory",
            "type": "::",
            "args": ["Title", "RequestContext"]
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/MediaWiki.php",
            "line": 861,
            "function": "performRequest",
            "class": "MediaWiki",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/includes/MediaWiki.php",
            "line": 524,
            "function": "main",
            "class": "MediaWiki",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/php-1.31.0-wmf.25/index.php",
            "line": 42,
            "function": "run",
            "class": "MediaWiki",
            "type": "->",
            "args": []
        }, {
            "file": "/srv/mediawiki/w/index.php",
            "line": 3,
            "function": "include",
            "args": ["string"]
        }]
    },
    "exception_id": "f95013bc",
    "caught_by": "mwe_handler"
}

Details

Related Gerrit Patches:

Event Timeline

Reedy created this task.Mar 16 2018, 12:04 AM
Restricted Application added projects: Commons, Multimedia. · View Herald TranscriptMar 16 2018, 12:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Tgr added a subscriber: Tgr.Mar 16 2018, 12:28 AM

Ugh, why are we still using JSON format for fatal traces?

Tgr triaged this task as High priority.Mar 16 2018, 12:33 AM

Caused by setting the hidepatrolled checkbox apparently.

Ugh, why are we still using JSON format for fatal traces?

Dunno. Let's file a task for that

Change 419957 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/core@master] Fix variable name in NewFilesPager::getQueryInfo

https://gerrit.wikimedia.org/r/419957

Change 419959 had a related patch set uploaded (by Reedy; owner: Gergő Tisza):
[mediawiki/core@wmf/1.31.0-wmf.25] Fix variable name in NewFilesPager::getQueryInfo

https://gerrit.wikimedia.org/r/419959

Change 419957 merged by Reedy:
[mediawiki/core@master] Fix variable name in NewFilesPager::getQueryInfo

https://gerrit.wikimedia.org/r/419957

Change 419959 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.25] Fix variable name in NewFilesPager::getQueryInfo

https://gerrit.wikimedia.org/r/419959

Mentioned in SAL (#wikimedia-operations) [2018-03-16T01:00:20Z] <reedy@tin> Synchronized php-1.31.0-wmf.25/includes/specials/pagers/NewFilesPager.php: Fix T189846 (duration: 00m 58s)

Reedy closed this task as Resolved.Mar 16 2018, 1:00 AM
Reedy assigned this task to Tgr.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:09 PM