Page MenuHomePhabricator

PAWS user server fails to load resources (javascript or css)
Closed, ResolvedPublic

Description

I was hoping this was something with my system, but I've now reproduced this in 3 different notebooks.

The main symptom is either a blank page when accessing the standard server interface (the with /tree at the end) or a page no stylized at all due to the lack of css.

Chrome shows net::ERR_SPDY_PROTOCOL_ERROR on main.js request
Edge shows weird errors (failure to open main.js)

This is sometimes accompanied by other errors or happens on different files. This also goes away and comes back intermittently .

Event Timeline

Chicocvenancio triaged this task as High priority.Mar 18 2018, 10:30 PM
Chicocvenancio created this task.
Chicocvenancio moved this task from Backlog to MVP (Most Valuable PAWS) on the PAWS board.
Chicocvenancio lowered the priority of this task from High to Low.Mar 18 2018, 11:10 PM

This seems to be related to cookies, specifically I noticed the user cookie was set for the wrong value user-chicocvenancio in my case. Deleting that specific cookie and reloading solved the issue. I did manage to reproduce the solution for a few other users (my bot and WMF accounts).
Hopefully this is not a common occurrence (maybe this only affects PAWS admins?), but I'll try to investigate why the wrong value was set in the first place.

Chicocvenancio closed this task as Resolved.Mar 15 2019, 5:39 PM