Page MenuHomePhabricator

Migrate CI job wikidata-query-rdf-maven-site-publish to use a Docker container
Closed, ResolvedPublic

Description

The job wikidata-query-rdf-maven-java8-docker-site-publish although the one on Nodepool pass ( wikidata-query-rdf-maven-site-publish ).

The wikidata-query-rdf-maven-site-publish job on Nodepool pass just fine.

The job Docker based job uses the container docker-registry.wikimedia.org/releng/java8:0.3.2 and it invokes maven with -DskipTests -Dmaven.test.skip=true clean install site site:stage.

There is apparently a path lookup failure:

[ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.6.0:java (start-proxy) on project tools:
An exception occured while executing the Java class. org.wikidata.query.rdf.tool.Proxy -> [Help 1]
[INFO] --- exec-maven-plugin:1.6.0:java (start-proxy) @ tools ---
[WARNING] 
java.lang.ClassNotFoundException: org.wikidata.query.rdf.tool.Proxy
    at java.net.URLClassLoader.findClass (URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass (ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass (ClassLoader.java:357)
    at org.codehaus.mojo.exec.ExecJavaMojo$1.run (ExecJavaMojo.java:270)
    at java.lang.Thread.run (Thread.java:748)
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] parent ............................................. SUCCESS [02:50 min]
[INFO] Shared code ........................................ SUCCESS [ 32.939 s]
[INFO] Wikidata Query RDF Testing Tools ................... SUCCESS [ 23.552 s]
[INFO] Blazegraph extension to improve performance for Wikibase SUCCESS [01:50 min]
[INFO] Blazegraph Service Package ......................... SUCCESS [02:36 min]
[INFO] Wikidata Query RDF Tools ........................... FAILURE [ 11.301 s]
[INFO] WDQS - Frontend .................................... SKIPPED
[INFO] Wikibase RDF Query Service ......................... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------

I guess it fails to find the proxy class, maybe because the tests are skipped:

Nodepoolmvn -B -f /src/pom.xml clean install site site:stage
Dockermvn -DskipTests -Dmaven.test.skip=true clean install site site:stage

Reproducible locally with:

$ docker pull docker-registry.wikimedia.org/releng/java8:0.3.2
$ cd projects/wikidata/query/rdf
$ install -m 2777 -d cache
$ docker run --rm -it --entrypoint=/bin/bash -v "$(pwd):/cache:/cache" -v "$(pwd):/src"  -v "$(pwd)/target:/src/target" docker-registry.wikimedia.org/releng/java8:0.3.2
nobody:/src$ mvn -DskipTests -Dmaven.test.skip=true install site site:stage

Details

Related Gerrit Patches:

Event Timeline

hashar triaged this task as High priority.Mar 19 2018, 1:38 PM
hashar created this task.
hashar updated the task description. (Show Details)Mar 19 2018, 1:48 PM
hashar updated the task description. (Show Details)Mar 19 2018, 2:00 PM
hashar updated the task description. (Show Details)
hashar updated the task description. (Show Details)Mar 19 2018, 2:06 PM

Change 420340 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] Use proper container for wikidata/query/rdf

https://gerrit.wikimedia.org/r/420340

The job had the wrong container and we need to NOT skip tests.

docker-registry.wikimedia.org/releng/java8-wikidata-query-rdf:0.1.2 clean install site site:stage

Change 420359 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] wikidata/query/rdf site goal requires tests

https://gerrit.wikimedia.org/r/420359

Change 420340 merged by jenkins-bot:
[integration/config@master] Use proper container for wikidata/query/rdf

https://gerrit.wikimedia.org/r/420340

Change 420359 merged by jenkins-bot:
[integration/config@master] wikidata/query/rdf site goal requires tests

https://gerrit.wikimedia.org/r/420359

Change 420362 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] Migrate wikidata query rdf publish job to Docker

https://gerrit.wikimedia.org/r/420362

Change 420362 merged by jenkins-bot:
[integration/config@master] Migrate wikidata query rdf publish job to Docker

https://gerrit.wikimedia.org/r/420362

hashar closed this task as Resolved.Mar 19 2018, 3:13 PM
hashar claimed this task.