Page MenuHomePhabricator

hastemplate-field should have the same behavior as the deepcat field
Closed, ResolvedPublic5 Story Points

Description

Current situation:

The hastemplate field allows for arbitrary input since there are use cases for this feature like searching for pages that still contain a non-existing template after deleting it. When adding a non-existing template to the search field, there is no indication of whether it exists or not after the tag was created.

Task:
We want to visually convey that the user is adding a non-existing template to their search by marking the text in red like it happens for categories.

Screenshots of the upload wizard's behavior:


Criteria:

  • There is a dropdown that suggests which templates exist, but you can also write your own template name that is not in the drop-down.
  • The tags of templates without a file page have red font.
  • There should be links to the template pages

Notes

  • We cannot use the category multiselect widget here, but we could look at it for inspiration.

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptMar 20 2018, 12:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Lea_WMDE set the point value for this task to 1.Mar 28 2018, 12:49 PM
Charlie_WMDE renamed this task from hastemplate-field should not allow arbitrary input to hastemplate-field should have the same behavior as the deepcat field.Apr 4 2018, 11:52 AM
Charlie_WMDE updated the task description. (Show Details)
Charlie_WMDE moved this task from Backlog to Tickets ready for pickup on the Advanced-Search board.
Lea_WMDE triaged this task as Normal priority.Apr 4 2018, 1:13 PM
Lea_WMDE updated the task description. (Show Details)
Lea_WMDE changed the point value for this task from 1 to 5.
Charlie_WMDE updated the task description. (Show Details)Apr 4 2018, 1:34 PM
Lea_WMDE updated the task description. (Show Details)Apr 18 2018, 1:22 PM

Tested, seems to work as intended.

Lea_WMDE closed this task as Resolved.May 30 2018, 10:34 AM