Page MenuHomePhabricator

python 3.3 builds are failing on travis-ci
Closed, ResolvedPublic

Description

https://travis-ci.org/wikimedia/pywikibot/jobs/356535819#L626

error in pendulum setup command: 'install_requires' must be a string or list of strings containing valid project/version requirement specifiers; Expected version spec in python-dateutil (>=2.6.0.0,<3.0.0.0) at  (>=2.6.0.0,<3.0.0.0)

Related: T184508: Drop support for Python 3.3

Details

Related Gerrit Patches:

Related Objects

Event Timeline

Dalba created this task.Mar 22 2018, 3:24 AM
Restricted Application added subscribers: pywikibot-bugs-list, Aklapper. · View Herald TranscriptMar 22 2018, 3:24 AM

Change 421250 had a related patch set uploaded (by Dalba; owner: Dalba):
[pywikibot/core@master] travis.yml: Upgrade setuptools before running script

https://gerrit.wikimedia.org/r/421250

Change 421250 merged by jenkins-bot:
[pywikibot/core@master] travis.yml: Upgrade setuptools before running script

https://gerrit.wikimedia.org/r/421250

Framawiki closed this task as Resolved.Mar 22 2018, 8:27 PM
Framawiki assigned this task to Dalba.