Page MenuHomePhabricator

Reply to a Structured discussion message is it displayed while it is visible in Notifications and Contributions
Closed, InvalidPublic

Description

User:Waanders replied to a topic I'm following on MediaWiki org, as I see in the notifications and the contributions,, but I can't see the reply on the topic, history, or board.

Contributions where the reply appears:

https://www.mediawiki.org/wiki/Special:Contributions/Waanders

The reply doesn't appear on the topic page, despite being in the notification:

https://www.mediawiki.org/wiki/Topic:U9p9fo4exdoyq8eh

The history doesn't display the reply, and it hasn't been hidden or removed (if it was, it doesn't get audited at least, which would be weird):

https://www.mediawiki.org/w/index.php?title=Topic:U9p9fo4exdoyq8eh&action=history

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 22 2018, 5:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Trizek-WMF renamed this task from Reply lost to Reply to a Structured discussion message is it displayed while it is visible in Notifications and Contributions.Mar 22 2018, 5:08 PM

I've posted a test message below Ciencia Al Poder's message and now I can see Waanders message. That's wired.

Yeah, I now see both replies on that topic. Maybe something failed to update on redis/memcached, and the old cached data wasn't refreshed properly

This also happened to @jmatazzoni at https://www.mediawiki.org/wiki/Topic:U9pb2yqvw98167zo : I don't see his posts in a normal browser window, but in an incognito window I do.

AhmadF.Cheema added a subscriber: AhmadF.Cheema.EditedMar 22 2018, 6:33 PM

As someone who was not following the topic mentioned in the OP, I'm pretty sure User:Waanders' reply was visible to me before too.

Also, @Ciencia_Al_Poder didn't you have a reply posted on the topic: using the word "head" throws error? It isn't visible and also does not appear in the topic's history. Maybe the revision was just suppressed making it invisible to me in history too.
Edit: The reply does appear on Project:Support desk's history page.

I think I have a good line on what his happening. When I'm logged OUT, I see the missing comments. When I'm logged IN, I don't see them. I confirmed this pattern on Mac Chrome, Safari and Firefox, using multiple accounts.

jmatazzoni triaged this task as Unbreak Now! priority.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptMar 22 2018, 6:48 PM

I think I have a good line on what his happening. When I'm logged OUT, I see the missing comments. When I'm logged IN, I don't see them. I confirmed this pattern on Mac Chrome, Safari and Firefox, using multiple accounts.

Ugh, yes, that's true, I can confirm that. However, the topic history doesn't reflect the new comment, being logged-in or in private browser, until someone adds another comment to it. I'm not able to see other instances of this problem on recent topics. I wonder if it was a temporal problem that has been fixed itself, or it's an intermittent problem.

Data about the messages in each topic is probably cached in the object cache, and a failure to update the cached data when the new message is posted can cause this behavior. If that's the case, the problem can easily affect other areas of the wiki, like pages displaying old versions, images not reflecting new dimensions after an upload, etc.

First weird finding: the updated version of the topic (6 comments: Kerry, Pigsonthewing, Joe, Kerry 3x) is cached in Varnish, but the version with only the first 2 comments (Kerry and Pigsonthewing) is what I get when I hit the app server directly. This happens both when I'm logged in and when I go to a URL like https://www.mediawiki.org/wiki/Topic:U9pb2yqvw98167zo?roan=1 in an incognito window. So somehow this topic has gotten screwed up either in the backend or one of its caches, but Varnish was never told to purge its version.

I posted a reply to that topic and that seems to have fixed it. The missing comments are back, and also appear in the history. I don't know what happened here, but most likely Flow's internal cache (WANCache) was populated wrongly somehow.

My ability to debug this was further impeded by the fact that logstash doesn't seem to capture DB queries in debug mode any more.

My ability to debug this was further impeded by the fact that logstash doesn't seem to capture DB queries in debug mode any more.

Filed as T190455: Logstash no longer captures DB queries in debug mode

Catrope lowered the priority of this task from Unbreak Now! to High.Apr 6 2018, 5:14 PM

It looks like this hasn't been happening recently, downgrading from UBN

Catrope closed this task as Invalid.Jul 3 2018, 6:12 PM

This hasn't been reported for a while, so I'll assume this was fixed or magically went away. Please reopen if it happens again.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJul 3 2018, 6:12 PM