Page MenuHomePhabricator

Last Visual Change is wrong for emulated mobile on Browsertime/WebPageReplay
Closed, ResolvedPublic

Description

This was broken in Chrome since a couple of releases ago, let me add the upstream bug later. The problem is that the width of the window changes at the end of the test and that is picked up as a last visual change.

I think there's a workaround to set the initial window size using Chrome command line (so it is the same as we later set). I did a quick try and the "blink" at the end is gone but something else is picked up as last change, let me try it some more.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2018, 10:48 AM
Peter triaged this task as Low priority.Mar 26 2018, 7:55 PM
Peter moved this task from Inbox to Backlog: Small & Maintenance on the Performance-Team board.

There's a couple of things going on here:

What we compare in WebPageTest vs Browsertime isn't the same. For WebPageTest we always load the "Download" graphic, we don't do that with Browsertime (simulating iPhone 6), so right now we cannot compare the last visual change.

Visual Metrics picks up a change I cannot spot with my eyes:
1.2 s

8.6 s

I have the original video so I'll file an upstream issue.

I could change configuration to make this go away (by letting the Visual Metrics pickup the viewport). It will go out the next time we do an update.

I filed an upstream bug: https://github.com/WPO-Foundation/visualmetrics/issues/28

The problem is that Visual Metrics pick up the wrong last visual change when we try to emulate small screens.

I'll keep an on this now and will keep pinging the upstream issue until we get help since this also affects our visual element metrics.

Got feedback from Pat and he says that it could be Chrome that anti-alias the text onLoad ... that match that thing happens really late. Lets see if there's a way to get rid off that.

Peter moved this task from Doing to Radar on the Performance-Team board.Sep 24 2018, 5:43 PM
Peter edited projects, added Performance-Team (Radar); removed Performance-Team.
Krinkle moved this task from Inbox to Blocked or Needs-CR on the Performance-Team board.
Peter closed this task as Resolved.Feb 19 2019, 9:43 PM

This was fixed in T215160

Restricted Application added a subscriber: Gilles. · View Herald TranscriptFeb 19 2019, 9:43 PM