Page MenuHomePhabricator

Copy pasting wikitext between two NWE windows causes <nowiki>
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Open a page using NWE
  2. Copy entire content
  3. Now open another page using NWE
  4. Paste the copied content

I used the following page as a source: https://en.wikipedia.beta.wmflabs.org/wiki/Nowiki

Event Timeline

Restricted Application added subscribers: jeblad, Aklapper. · View Herald TranscriptMar 23 2018, 10:45 PM
matmarex added a subscriber: matmarex.

Pretty sure we have a duplicate report for this somewhere. It only occurs in Chrome (or at least, doesn't occur in Firefox).

DLynch claimed this task.Mar 28 2018, 5:00 PM
DLynch added a subscriber: DLynch.

I couldn't find a duplicate with some quick searching.

@DLynch Sorry, it was not a separate task, I just found the comment I was thinking of: T153315#4020939

Change 422955 had a related patch set uploaded (by DLynch; owner: DLynch):
[VisualEditor/VisualEditor@master] PlainTextStringTransferHandler: Allow as paste

https://gerrit.wikimedia.org/r/422955

This patch is a shining example of lots of debugging and history-trawling resulting in a tiny change.

Change 422955 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] PlainTextStringTransferHandler: Allow as paste

https://gerrit.wikimedia.org/r/422955

Change 424482 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (3ea11b8b1)

https://gerrit.wikimedia.org/r/424482

Change 424482 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (3ea11b8b1)

https://gerrit.wikimedia.org/r/424482

DLynch closed this task as Resolved.Apr 9 2018, 3:25 PM

This resolves the wikitext / other-plain-text cases. The parent (T153315) is unaffected, since that's not text/plain.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptApr 9 2018, 3:25 PM

Change 427436 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] Add a plain text paste transfer handler for source mode

https://gerrit.wikimedia.org/r/427436

Change 427435 had a related patch set uploaded (by DLynch; owner: DLynch):
[VisualEditor/VisualEditor@master] PlainTextStringTransferHandler: Forbid for paste again

https://gerrit.wikimedia.org/r/427435

Change 427435 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] PlainTextStringTransferHandler: Forbid for paste again

https://gerrit.wikimedia.org/r/427435

Change 428394 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (04137a1ed)

https://gerrit.wikimedia.org/r/428394

Change 428394 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (04137a1ed)

https://gerrit.wikimedia.org/r/428394

Change 427436 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Add a plain text paste transfer handler for source mode

https://gerrit.wikimedia.org/r/427436