Page MenuHomePhabricator

Dialog asking "Do you really want to abandon your edit?" appears while saving an edit with mobile VE
Closed, ResolvedPublic

Description

Dialog asking "Do you really want to abandon your edit?" appears very briefly while saving an edit with mobile VE

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterVisualEditorOverlay: don't show leave-confirm dialog after saving

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2018, 10:49 PM
Deskana changed the task status from Open to Stalled.Mar 27 2018, 6:56 PM

I can't reproduce this. Can you give more details?

Ryasmeen added a comment.EditedMar 27 2018, 9:39 PM

Okay, so this is reproducible in Chrome and Firefox but not in Safari. I am getting this error every time I try to save an edit. Video capture attached if that helps:

Ryasmeen changed the task status from Stalled to Open.Mar 29 2018, 10:16 PM

Change 434014 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/MobileFrontend@master] VisualEditorOverlay: don't show leave-confirm dialog after saving

https://gerrit.wikimedia.org/r/434014

DLynch claimed this task.May 20 2018, 10:55 AM
DLynch edited projects, added VisualEditor (Current work); removed VisualEditor.
DLynch moved this task from Incoming to Code review on the VisualEditor (Current work) board.

Change 434014 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] VisualEditorOverlay: don't show leave-confirm dialog after saving

https://gerrit.wikimedia.org/r/434014

Deskana closed this task as Resolved.May 23 2018, 3:36 PM
Deskana triaged this task as Medium priority.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 23 2018, 3:36 PM