Page MenuHomePhabricator

Some of the borders on maps.wikimedia.org are outdated
Closed, DuplicatePublic

Description

I fixed the Cayo District border in OpenStreetMap in December 2016, but our maps still have the old border:
Our version: https://maps.wikimedia.org/#14/17.4755/-88.5907
OSM version: https://www.openstreetmap.org/#map=14/17.4755/-88.5907
Changeset: https://www.openstreetmap.org/changeset/44243433#map=10/17.3756/-88.5344

(The old version is a very rough approximation, while the new version is based on a detailed 1:500,000 map of the area.)

Details

Related Gerrit Patches:
operations/puppet : productionmaps: fixed typo in populate_admin() cron
operations/puppet : productionmaps: run populate_admin() regularly

Event Timeline

kaldari created this task.Mar 24 2018, 2:45 AM
Restricted Application added a project: Discovery. · View Herald TranscriptMar 24 2018, 2:45 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Aklapper renamed this task from Some of the boders on maps.wikimedia.org are outdated to Some of the borders on maps.wikimedia.org are outdated.Mar 24 2018, 10:15 AM

@Pnorman - Any idea what's wrong here?

Production is using osm-bright.tm2source, so I'm not as familiar with it, but my guess is we need to run the populate_admin function. We're regularly updating the water shapefiles but don't seem to be doing the same for the admin SQL.

@Gehel: ^ Is that something that you could do? Sounds like we should set up populate_admin() to run from a cronjob, maybe once a week or month.

Change 425524 had a related patch set uploaded (by Gehel; owner: Gehel):
[operations/puppet@production] maps: run populate_admin() regularly

https://gerrit.wikimedia.org/r/425524

Gehel reopened this task as Open.Apr 13 2018, 12:48 PM
Gehel closed this task as a duplicate of T192116: Run populate_admin in transaction.

Change 425524 merged by Gehel:
[operations/puppet@production] maps: run populate_admin() regularly

https://gerrit.wikimedia.org/r/425524

Mentioned in SAL (#wikimedia-operations) [2018-04-16T08:49:46Z] <gehel> first manual run of populate_admin() for maps[12]001 - T190605

Change 426866 had a related patch set uploaded (by Gehel; owner: Gehel):
[operations/puppet@production] maps: fixed typo in populate_admin() cron

https://gerrit.wikimedia.org/r/426866

Change 426866 merged by Gehel:
[operations/puppet@production] maps: fixed typo in populate_admin() cron

https://gerrit.wikimedia.org/r/426866

Gehel triaged this task as High priority.Apr 16 2018, 8:59 AM
Gehel added a subscriber: SBisson.

populate_admin() is running. Tiles have not been re-generated, we can either wait for OSM replication to occur on those tiles, or force a re-generation. I'll let @Pnorman or @SBisson take care of that part.

Is it feasible to tell which tiles should be regenerated based on one execution of populate_admin()? If so, we could set it up like osm replication.

If not, is there enough changes in osm data to guarantee that every tile will be re-generated often enough? We could analyse SELECT WRITETIME(tile) FROM v3.tiles to find out.

Is it feasible to tell which tiles should be regenerated based on one execution of populate_admin()? If so, we could set it up like osm replication.

No. Or at least not without a bunch of work on a process we're getting rid of.

We have the same problem with coastlines too.