Page MenuHomePhabricator

Wikipedia: admin selectable size limit in local wiki file uploads
Closed, DeclinedPublic

Description

  • Pd or cc-by-sa files, uploaded in Wikipedias locally, are afterwards moved to Wikimedia Commons by admins. Users lose their statistics and admins have more work to do that could be avoided.
  • Fair use files, uploaded in Wikipedias locally, are deleted if oversized, or resized. This is more work for users and admins.

Files types are selected from a file type list, for locally uploaded files. If each file type had an upload limit in dimension size (total number of pixels: XX px * YY px) this would:

  • assist fair use uploads as file size could be automatically checked and denied before publishing
  • give the option to restrict new pd or cc-by-sa uploads locally, and force using Wikimedia Commons from that point of time and beyond.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 26 2018, 9:54 AM
ManosHacker updated the task description. (Show Details)Mar 26 2018, 10:01 AM
ManosHacker updated the task description. (Show Details)Mar 26 2018, 10:38 AM
Aklapper changed the task status from Open to Stalled.Mar 26 2018, 10:46 AM
Aklapper removed a project: MediaWiki-Interface.

Thanks for reporting this. It is unclear what this task is about.
"Local upload options" can be restricted to whatever you set them to in your MediaWiki configuration if you run a MediaWiki server. I don't know where to "parameterize picture area size" and what specific limit you refer to in "denied on limit exceed". This also sounds like two very different topic, and tasks should only cover exactly one topic.
Please follow https://mediawiki.org/wiki/How_to_report_a_bug and structure your tasks in three section (clear steps to reproduce the problem; actual outcome; expeted outcome).
This task summary also mentions "Wikipedia". If this is a request about the configuration of one of the 300 Wikipedia websites out there then please see https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes

gh87 added a subscriber: gh87.EditedMar 26 2018, 10:50 AM

Either this task should be closed as "invalid" or "declined", or be re-modified. Some US-ineligible images cannot be transferred to Wikimedia Commons because they are still copyrighted in their countries of origins, like the EDGE magazine logo and Australian Aboriginal Flag. Also, some other 1600+ images tagged as "esoteric" cannot be transferred to Wikimedia Commons.

I must also point out that NonFreeWiki and its alternative have been proposed (and debated?). Furthermore, Wikimedia Commons and Wikipedia expect non-US works to be normally free in the US and in their countries of origin.

The proposal is for Wikipedias mainly. Files that are already there are not affected, only new uploads. In fact all that is needed is implementing the size limit for choices and each wiki can decide for itself.

gh87 added a comment.EditedMar 26 2018, 11:33 AM

I also oppose #1 (broadly restricting options to just fair use). This would force a user to upload a newer esoteric or US-ineligible file into Commons or incorrectly tag either one as "fair use", which is not what we're supposed to do.

About #2 (broadly imposing size limits), which I admittedly overlooked... :( This should not apply to US-ineligible or free but esoteric files.

ManosHacker renamed this task from Wikipedia: restrict local wiki file upload to Wikipedia: admin selectable size limit in local wiki file uploads.Mar 26 2018, 11:56 AM
ManosHacker updated the task description. (Show Details)
gh87 added a comment.Mar 26 2018, 12:01 PM

Hmm... Much better improvements, but... maybe this should need community discussion(s), don't you think? How about en.WP's Village pump for policy-related issues?

On topic 1: File size/dimensions: How would anybody be able to define an "upload limit in dimension size" directly related to enforcing "fair use"?

On topic 2:

give the option to restrict new pd or cc-by-sa uploads locally

Did you mean "disallow" when you wrote "restrict"?

In general, please create separate tasks for separate topics. Thanks.

Please forgive my english, I did mean disallow.

The functionality asked is basically only one, file size check. How it is going to be used is another thing and English Wikipedia VP is the place for it to be discussed, thank you.

As discussed in Greek village pump, different fair use file types might need different size limits. Setting these limits is for each community to decide, too.

gh87 added a comment.Mar 27 2018, 12:34 AM

I see that the discussion is occurring at Greek Wikipedia. I don't understand Greek, so I used Google Translate. From reading the Translation, I see no consensus to support the plan.

The only consensus, so far, is in the usefulness of automatic disallowing a fair use file creation onwiki, if it is oversized. The two step procedure (upload, create file page), that gives the option to check image area dimensions before page creation, was not initially realized. A constructive point on the initial proposal was that different fair use file types might need different file size limit. I will let the full conversation find its balance on all topics before I go to English VP.

Aklapper closed this task as Declined.May 19 2020, 10:47 AM

@ManosHacker: Given the previous discussion I am to boldly declining this stalled task.

gh87 removed a subscriber: gh87.May 19 2020, 9:38 PM