Page MenuHomePhabricator

Add tool to write MassMessage to all pages linked to a Wikidata item
Closed, ResolvedPublic

Description

It would be useful to have a tool that emits MassMessage syntax for all pages linked to a certain Wikidata item (typically a project page).

Need:

I'm a community liaison and I want to share an announcement and reach all the editors across the projects who work on Lua modules. I'd like to send a message to all the wikis having a Project:Lua, on the talk page of this project. For this kind of action I use MassMessage, that requests a list of pages with a specific format. I know that I can find all the links to Project:Lua in a Wikidata item (Q6811431) but I don't know how to get the list of all these pages, formatted in the way I need for MassMessage.

Features:

  • specify one or more items (e. g. Project:Lua (Q6811431), optionally falling back to the generic Project:Village pump (Q16503) for projects that don’t have a specific Lua page)
  • optionally, specify a wikigroup to limit to projects in that group (e. g. wiktionary)
  • optionally, link to talk pages instead of the main page
  • either emit MassMessage syntax or directly send the MassMessage – but tbh I would prefer emitting MassMessage so that the sender can verify the page list before sending

For reference, MassMessage syntax looks like this:

1# {{target|page=Wikipediabespreking:Lua|site=af.wikipedia.org/}}
2# {{target|page=نقاش ويكيبيديا:لوا|site=ar.wikipedia.org/}}
3# {{target|page=विकिपीडिया वार्ता:लुआ|site=bh.wikipedia.org/}}
4# {{target|page=উইকিপিডিয়া আলোচনা:লুয়া|site=bn.wikipedia.org/}}
5# {{target|page=Viquipèdia Discussió:Lua|site=ca.wikipedia.org/}}
6# {{target|page=Commons talk:Lua|site=commons.wikimedia.org/}}
7# {{target|page=Wikipedia-diskussion:Lua|site=da.wikipedia.org/}}
8# {{target|page=Wikipedia Diskussion:Lua|site=de.wikipedia.org/}}
9# {{target|page=Wikipedija diskusija:Lua|site=dsb.wikipedia.org/}}
10# {{target|page=Wikipedia talk:Lua|site=en.wikipedia.org/}}
11# {{target|page=Wiktionary talk:Scribunto|site=en.wiktionary.org/}}
12# {{target|page=Vikipedia diskuto:Lua|site=eo.wikipedia.org/}}
13# {{target|page=Wikipedia discusión:Lua|site=es.wikipedia.org/}}
14# {{target|page=بحث ویکی‌پدیا:لوآ|site=fa.wikipedia.org/}}
15# {{target|page=Keskustelu ohjeesta:Lua|site=fi.wikipedia.org/}}
16# {{target|page=Discussion Wikipédia:Lua|site=fr.wikipedia.org/}}
17# {{target|page=Conversa Wikipedia:Módulos|site=gl.wikipedia.org/}}
18# {{target|page=વિકિપીડિયા ચર્ચા:Lua|site=gu.wikipedia.org/}}
19# {{target|page=שיחת ויקיפדיה:לואה|site=he.wikipedia.org/}}
20# {{target|page=Wikipedija diskusija:Lua|site=hsb.wikipedia.org/}}
21# {{target|page=Wikipédia-vita:Lua|site=hu.wikipedia.org/}}
22# {{target|page=Discussion Wikipedia:Modulo|site=ia.wikipedia.org/}}
23# {{target|page=Pembicaraan Wikipedia:Lua|site=id.wikipedia.org/}}
24# {{target|page=Wikipedia tungtungan:Lua|site=ilo.wikipedia.org/}}
25# {{target|page=Discussioni aiuto:Moduli Lua|site=it.wikibooks.org/}}
26# {{target|page=Discussioni aiuto:Moduli|site=it.wikipedia.org/}}
27# {{target|page=Discussioni aiuto:Moduli|site=it.wikiquote.org/}}
28# {{target|page=Discussioni aiuto:Moduli|site=it.wikiversity.org/}}
29# {{target|page=Discussioni aiuto:Moduli|site=it.wikivoyage.org/}}
30# {{target|page=Discussioni aiuto:Moduli|site=it.wiktionary.org/}}
31# {{target|page=Wikipedia‐ノート:Lua|site=ja.wikipedia.org/}}
32# {{target|page=위키백과토론:루아|site=ko.wikipedia.org/}}
33# {{target|page=Gotûbêja Wîkîpediyayê:Lua|site=ku.wikipedia.org/}}
34# {{target|page=Vikipēdijas diskusija:Lua|site=lv.wikipedia.org/}}
35# {{target|page=विकिपीडिया चर्चा:लुआ|site=mr.wikipedia.org/}}
36# {{target|page=Perbincangan Wikipedia:Lua|site=ms.wikipedia.org/}}
37# {{target|page=Wikipedia talk:Lua|site=my.wikipedia.org/}}
38# {{target|page=Wikipedia-diskusjon:Lua|site=no.wikipedia.org/}}
39# {{target|page=ଉଇକିପିଡ଼ିଆ ଆଲୋଚନା:ଲୁଆ|site=or.wikipedia.org/}}
40# {{target|page=ਵਿਕੀਪੀਡੀਆ ਗੱਲ-ਬਾਤ:ਸਕਰਿਬੁੰਟੋ|site=pa.wikipedia.org/}}
41# {{target|page=Dyskusja Wikipedii:Lua|site=pl.wikipedia.org/}}
42# {{target|page=Wikipédia Discussão:Lua|site=pt.wikipedia.org/}}
43# {{target|page=Discuție Wikipedia:Lua|site=ro.wikipedia.org/}}
44# {{target|page=Обсуждение Викиновостей:Модули|site=ru.wikinews.org/}}
45# {{target|page=Обсуждение Википедии:Модули|site=ru.wikipedia.org/}}
46# {{target|page=विकिपीडियासम्भाषणम्:Lua|site=sa.wikipedia.org/}}
47# {{target|page=بحث:لُووا|site=sd.wikipedia.org/}}
48# {{target|page=Razgovor o Wikipedia:Lua|site=sh.wikipedia.org/}}
49# {{target|page=විකිපීඩියා සාකච්ඡාව:Lua|site=si.wikipedia.org/}}
50# {{target|page=Pogovor o Wikipediji:Lua|site=sl.wikipedia.org/}}
51# {{target|page=Obrolan Wikipedia:Lua|site=su.wikipedia.org/}}
52# {{target|page=Wikipediadiskussion:Lua|site=sv.wikipedia.org/}}
53# {{target|page=คุยเรื่องวิกิพีเดีย:ลูอา|site=th.wikipedia.org/}}
54# {{target|page=Vikipedi tartışma:Lua|site=tr.wikipedia.org/}}
55# {{target|page=Wikipedia talk:Lua|site=wuu.wikipedia.org/}}
56# {{target|page=Extension talk:Scribunto|site=www.mediawiki.org/}}
57# {{target|page=Wikipedia thó-lūn:Lua|site=zh-min-nan.wikipedia.org/}}
58# {{target|page=Wikipedia talk:Lua|site=zh-yue.wikipedia.org/}}
59# {{target|page=Wikipedia talk:Lua|site=zh.wikipedia.org/}}
60# {{target|page=Уикипедия беседа:Модули|site=bg.wikipedia.org/}}

I originally wrote a query for @Lea_Lacroix_WMDE with just the first two features (P6900 – note that the line breaks in the query output won’t show until T189937, so you have to copy the HTML source), and then more recently a shell script to link to talk pages as well (P6901 – but without wikigroup and multiple items support). It would be nice to have this wrapped in a nice, easy-to-use tool.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 27 2018, 10:21 AM

Thanks for creating the prototype and setting up the ticket. This will be useful for people doing cross-wiki communication (community liaisons, volunteers).

The specifications seem good. I'd support the idea of only generating the list in the first place. Then the user can copy it in a wikipage, and use the MassMessage tool as it is currently.

If possible, it could be nice to have the action of creating a sub-page of the userpage, with the result of the script.

  • I'm logged in on-wiki with my account Lea Lacroix (WMDE)
  • Once I have generated and verified my script, I have an action "copy it in a subpage of my userpage"
  • I can enter the title I want for this page, for example "Lua projects"
  • The page User:Lea Lacroix (WMDE)/Lua projects is created with the result of the script
  • I get a validation that this subpage has been created and a link to it

Note: in the syntax, the slash / needs to be removed at the end of the site url.

@Trizek-WMF @Johan @Quiddity @Keegan Can you have a look, tell us if such a tool would be useful for you, and if you would have extra requirements? :)

Elitre added a subscriber: Elitre.

Looks good to me!

This seems like a duplicate of T171617: Develop a tool for MassMessage users to generate distribution lists from Wikidata project pages...but why not implement this in MassMessage itself?

Sorry, I completely forgot about that older task (even though I was CCed on it).

I’m not familiar with the technical side of the MassMessage extension… would it make sense to add this to MassMessage itself? The current tool has a lot of wiki-specific overrides (page_data.py), I’m not sure how easy it would be to express that as configuration for the MassMessage extension.

Lucas_Werkmeister_WMDE closed this task as Resolved.Dec 3 2018, 11:41 AM
Lucas_Werkmeister_WMDE claimed this task.

I think we can close this task – the tool exists (https://tools.wmflabs.org/wdmm/), and all the features from the task description are available, except for directly sending the MassMessage (optional).

We can discuss over at T171617: Develop a tool for MassMessage users to generate distribution lists from Wikidata project pages whether that task is now also resolved or more should be done.