Page MenuHomePhabricator

Uncaught Error: Unknown dependency: ext.cards
Closed, InvalidPublic

Description

At https://freephile.qualitybox.us/wiki/Trump?debug=true I get the following error in the JS console

load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=chameleon&version=07f8iog:11461 Uncaught Error: Unknown dependency: ext.cards
    at sortDependencies (load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=chameleon&version=07f8iog:11461)
    at String.<anonymous> (load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=chameleon&version=07f8iog:11522)
    at Function.each (load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=chameleon&version=07f8iog:384)
    at resolve (load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=chameleon&version=07f8iog:11521)
    at Object.using (load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=chameleon&version=07f8iog:12342)
    at loadRelatedArticles (index.js?35fee:30)
    at index.js?35fee:53
    at index.js?35fee:55

Disabling the RelatedArticles extension makes the error go away.

Product Version
MediaWiki 1.28.3 (e9f315c)
2017-11-15T17:01:08
PHP 5.6.34 (apache2handler)
MariaDB 5.5.56-MariaDB
ICU 50.1.2
Elasticsearch 2.4.6
Lua 5.1.5

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 28 2018, 2:58 AM
Aklapper closed this task as Invalid.EditedMar 28 2018, 8:49 AM

MediaWiki 1.28.3

1.28.3 is an old unsupported version. Please reopen this task if this problem still happens in a supported version. Thanks.

(For the records, before I closed this task I grep'ed the extension codebase for ext.cards in both git master and the REL1_28 branch with differing results.)