Page MenuHomePhabricator

Usernames remain disabled when enabling local exception for email-blacklist
Closed, ResolvedPublic

Description

To reproduce:

  1. (no need to enter any values for any preferences) go to Special:GlobalPreferences and enable email-blacklist globally;
  2. go back to Special:Preferences and check the "Set a local exception for this global preference." checkbox;
  3. the associated field should become enabled;
  4. try entering a username: the autocomplete will work, but all of the options will be greyed out. There is sometimes also a bug where as soon as the dropdown list opens, the page is scrolled back to the top.

If you save the preferences form, the field works correctly (i.e. because it's already enabled when the page loads).

Is this something strange about how the UsersMultiselectWidget is disabled/enabled? It seems that it's being infused correctly, because it does actually become enabled and does work. The code in question is around ext.GlobalPreferences.local.js line 19.

Event Timeline

Restricted Application added a project: Community-Tech. · View Herald TranscriptMar 28 2018, 6:50 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I just tested this (on Chrome 66.0.3359.181 on OSX 10.13.4) and now the widget has a different behavior than described by Sam above. On both Global Preferences and local Preferences (during a local override) the username 'pills' appear correct but there are no username suggestions.

Not a blocker for sitewide release.

Niharika closed this task as Resolved.Jul 28 2018, 12:36 AM
Niharika claimed this task.
Niharika moved this task from Product backlog to Archive on the Community-Tech board.
Niharika added a subscriber: Niharika.

This has now been fixed.