Page MenuHomePhabricator

MWException from line 154 of /srv/mediawiki/php-1.31.0-wmf.26/extensions/Translate/utils/MessageHandle.php: called before isValid
Closed, ResolvedPublic

Description

Error Message

MWException from line 154 of /srv/mediawiki/php-1.31.0-wmf.26/extensions/Translate/utils/MessageHandle.php: called before isValid

Stack Trace

#0 /srv/mediawiki/php-1.31.0-wmf.26/extensions/Translate/api/ApiQueryMessageCollection.php(143): MessageHandle->getGroup()
#1 /srv/mediawiki/php-1.31.0-wmf.26/extensions/Translate/api/ApiQueryMessageCollection.php(22): ApiQueryMessageCollection->run()
#2 /srv/mediawiki/php-1.31.0-wmf.26/includes/api/ApiQuery.php(249): ApiQueryMessageCollection->execute()
#3 /srv/mediawiki/php-1.31.0-wmf.26/includes/api/ApiMain.php(1580): ApiQuery->execute()
#4 /srv/mediawiki/php-1.31.0-wmf.26/includes/api/ApiMain.php(542): ApiMain->executeAction()
#5 /srv/mediawiki/php-1.31.0-wmf.26/includes/api/ApiMain.php(513): ApiMain->executeActionWithErrorHandling()
#6 /srv/mediawiki/php-1.31.0-wmf.26/api.php(94): ApiMain->execute()
#7 /srv/mediawiki/w/api.php(3): include(string)
#8 {main}

Notes

Event Timeline

mmodell created this task.Mar 28 2018, 7:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 28 2018, 7:09 PM

This is not a new one, seen it before. Which wiki is this? It's caused by having Translate's message index out of date or invalid titles somewhere.

Change 424606 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] Avoid exception in ApiQueryMessageCollection

https://gerrit.wikimedia.org/r/424606

KartikMistry triaged this task as Normal priority.
KartikMistry moved this task from Backlog to In Review on the Language-2018-Apr-June board.
KartikMistry added a subscriber: KartikMistry.

Change 424606 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Avoid exception in ApiQueryMessageCollection

https://gerrit.wikimedia.org/r/424606

Arrbee moved this task from In Review to QA on the Language-2018-Apr-June board.Apr 10 2018, 7:04 AM
Etonkovidova closed this task as Resolved.Apr 19 2018, 2:48 AM
Etonkovidova added a subscriber: Etonkovidova.

Checked @deployment-fluorine02:/srv/mw-log - currently exception.log does not have any errors recorded for extensions/Translate.

Nikerabbit moved this task from QA to Done on the Language-2018-Apr-June board.Apr 19 2018, 8:43 AM