Page MenuHomePhabricator

2017 wikitext editor's toolbar blocking clickable tabs of a page under Modern skin
Closed, InvalidPublicBug

Description

Steps to Reproduce:

  1. Go to Beta Features settings and enable the 2017 wikitext editor
  2. Go to Appearances tab at the Preferences settings and then select "Modern" as your skin
  3. Go to any page you want to edit.

Actual Results:

The newest editor's toolbar blocks clickable tabs from view, like "Article" and "Edit this page", forcing a reader to either click "Back" twice to go back to the article or "Publish changes". This occurs at most browsers, like IE11, Chrome, and Firefox.

Expected Results:

The toolbar must not block a page's clickable tabs.

Event Timeline

gh87 created this task.Mar 30 2018, 4:34 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptMar 30 2018, 4:34 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Deskana triaged this task as Lowest priority.Apr 3 2018, 6:57 PM
Deskana added a subscriber: Deskana.

Modern is not an officially supported skin for the visual and 2017 wikitext editors: https://www.mediawiki.org/wiki/VisualEditor/Skin_requirements

It's also not an officially supported skin at all as far as I know, but I don't have a citation for that.

Deskana moved this task from To Triage to Freezer on the VisualEditor board.Apr 3 2018, 6:58 PM
Dvorapa added a comment.EditedApr 3 2018, 8:44 PM

@Deskana It is between main 6 skins allowed on Wikipedias. On the Czech Wikipedia it is the second one under Vector in preferences

This should be probably solved on skin's side, right? Per requirements Deskana shared..

TheDJ added a subscriber: TheDJ.Apr 4 2018, 9:14 AM

@Dvorapa, yeah its available, but we don't support it (the only supported skins are Vector, Minerva (mobile), and Monobook. The other skins are community maintained on a best effort basis..

But if VE doesn't support that skin, it shouldn't allow you to use the feature in that setup to begin with.

@Deskana It is between main 6 skins allowed on Wikipedias. On the Czech Wikipedia it is the second one under Vector in preferences

I'm aware of that. In the Wikimedia world, that doesn't mean it's maintained. It's an anti-pattern in this movement to allow unmaintained things to remain in production. I'd prefer to remove it altogether, but the fight that that would cause isn't worth copious amount of time it'd take up.

But if VE doesn't support that skin, it shouldn't allow you to use the feature in that setup to begin with.

Agreed. I wonder how many people actually use the visual editor in those skins?

matmarex closed this task as Invalid.Apr 4 2018, 9:10 PM
matmarex claimed this task.
matmarex added a subscriber: matmarex.

VisualEditor does not normally load on the Modern skin. It is definitely not compatible with it, even by the rules of the "Skin requirements" page linked above – there is no #content element in it. It does not load for me locally, and instead prints a warning in browser console.

However, English Wikipedia must have some truly magical hack somewhere, because running $( '#content' ) returns the #mw_content element instead of nothing, which is enough to fool VisualEditor into trying to load. This is, however, not our problem :)

For reference, I found the hack: https://en.wikipedia.org/wiki/MediaWiki:Modern.js. document.getElementById is overridden there.