Page MenuHomePhabricator

Wikibooks in English "Calculus/Print_version" is not retrievable through REST API
Closed, DeclinedPublic

Description

Here is the GET request, like you can see, even if HTTP 200, I get an empty content AND a warning.

Might be a duplicate of T86611... but quite unsure about that.

$ curl -v "https://en.wikibooks.org/w/api.php?action=visualeditor&format=json&paction=parse&page=Calculus%2FPrint_version&oldid=3101846"
* Hostname was NOT found in DNS cache
*   Trying 208.80.154.224...
* Connected to en.wikibooks.org (208.80.154.224) port 443 (#0)
* successfully set certificate verify locations:
*   CAfile: none
  CApath: /etc/ssl/certs
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, CERT (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using ECDHE-ECDSA-AES256-GCM-SHA384
* Server certificate:
* 	 subject: C=US; ST=California; L=San Francisco; O=Wikimedia Foundation, Inc.; CN=*.wikipedia.org
* 	 start date: 2017-11-03 03:42:02 GMT
* 	 expire date: 2018-11-22 07:59:59 GMT
* 	 subjectAltName: en.wikibooks.org matched
* 	 issuer: C=BE; O=GlobalSign nv-sa; CN=GlobalSign Organization Validation CA - SHA256 - G2
* 	 SSL certificate verify ok.
> GET /w/api.php?action=visualeditor&format=json&paction=parse&page=Calculus%2FPrint_version&oldid=3101846 HTTP/1.1
> User-Agent: curl/7.35.0
> Host: en.wikibooks.org
> Accept: */*
> 
< HTTP/1.1 200 OK
< Date: Sat, 31 Mar 2018 16:20:48 GMT
< Content-Type: application/json; charset=utf-8
< Transfer-Encoding: chunked
< Connection: keep-alive
* Server mw1344.eqiad.wmnet is not blacklisted
< Server: mw1344.eqiad.wmnet
< X-Powered-By: HHVM/3.18.6-dev
< X-Content-Type-Options: nosniff
< Cache-control: private, must-revalidate, max-age=0
< P3P: CP="This is not a P3P policy! See https://en.wikibooks.org/wiki/Special:CentralAutoLogin/P3P for more info."
< X-Frame-Options: DENY
< Content-Disposition: inline; filename=api-result.json
< Vary: Accept-Encoding
< Backend-Timing: D=2089499 t=1522513246467289
< X-Varnish: 434122591, 549146762
< Via: 1.1 varnish (Varnish/5.1), 1.1 varnish (Varnish/5.1)
< Accept-Ranges: bytes
< Age: 0
< X-Cache: cp1065 pass, cp1065 pass
< X-Cache-Status: pass
< Strict-Transport-Security: max-age=106384710; includeSubDomains; preload
< Set-Cookie: WMF-Last-Access=31-Mar-2018;Path=/;HttpOnly;secure;Expires=Wed, 02 May 2018 12:00:00 GMT
< Set-Cookie: WMF-Last-Access-Global=31-Mar-2018;Path=/;Domain=.wikibooks.org;HttpOnly;secure;Expires=Wed, 02 May 2018 12:00:00 GMT
< X-Analytics: ns=0;page_id=52962;https=1;nocookies=1
< X-Client-IP: 10.68.16.224
< Set-Cookie: GeoIP=:::::v4; Path=/; secure; Domain=.wikibooks.org
< 
* Connection #0 to host en.wikibooks.org left intact
{"warnings":{"result":{"*":"This result was truncated because it would otherwise be larger than the limit of 12,582,912 bytes."}}}

Event Timeline

Kelson created this task.Mar 31 2018, 4:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 31 2018, 4:25 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMar 2 2020, 4:31 PM
Arlolra moved this task from Needs Triage to Backlog on the Parsoid board.Mar 2 2020, 5:27 PM
LGoto triaged this task as Low priority.Mar 27 2020, 4:12 PM
LGoto moved this task from Backlog to Needs Investigation on the Parsoid board.
Arlolra claimed this task.Apr 3 2020, 4:25 PM
Arlolra closed this task as Declined.Apr 3 2020, 10:57 PM

This isn't specific to Parsoid since
https://en.wikibooks.org/wiki/Calculus/Print_version
returns Fatal exception of type "WMFTimeoutException"

The pdf linked to from the top level page is 453 pages,
https://upload.wikimedia.org/wikipedia/commons/a/a3/Calculus.pdf

And it looks like this is trying to render something comparable,
https://en.wikibooks.org/w/index.php?title=Calculus/Print_version&action=edit

It seems like it used to be able to get to the point where it was telling you the page was too big but now it times out before getting there.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptApr 3 2020, 10:57 PM