Page MenuHomePhabricator

Some custom "undo" text on English Wikipedia has line breaks in the middle of words
Closed, InvalidPublic

Description

The screen that appears when carrying out an "undo" includes a message box near the top, "The edit can be undone...". In this box there is now a line break between the "c" and "h" of the word "changes". (Desktop view, Monobook skin)

Event Timeline

Noyster created this task.Apr 1 2018, 11:57 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 1 2018, 11:57 AM
Dereckson added a subscriber: Dereckson.

@Noyster could you take a screenshot?

gh87 added a subscriber: gh87.Apr 1 2018, 9:16 PM

I don't see line break at IE11 (pictured) or any other browser.

However, my monitor's resolution is 1680 x 1050. @Noyster What is your monitor's resolution, and which browser?

(1) 1280 x 800.
(2) Firefox 59.0.2.

Dereckson added a comment.EditedApr 1 2018, 10:42 PM

Thanks for the screenshot, it's more clear. I can repro on Vector skin too.

This behavior is caused by a CSS rule, word-break: break-all;

Reference: https://developer.mozilla.org/en-US/docs/Web/CSS/word-break

It's set in https://en.wikipedia.org/wiki/MediaWiki:Common.css

/* break words if they will overflow the content box */
.fmbox > tbody > tr > .mbox-text {
	word-break: break-all; /* break all, because it's a table-cell, that can grow if we use break-word */
}

You could discuss the issue at https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)

It's a design community choice from the English Wikipedia, not a design rule from the Monobook skin or other MediaWiki component.

gh87 removed a subscriber: gh87.Apr 2 2018, 3:13 AM
Aklapper closed this task as Invalid.Apr 2 2018, 7:38 AM
In T191167#4096232, Dereckson wrote:

It's a design community choice from the English Wikipedia, not a design rule from the Monobook skin or other MediaWiki component.

I am closing this task as invalid as it is about a problem in on-wiki content of a specific community and hence out of scope for tracking it in Wikimedia Phabricator.
For future reference, please include a link to reproduce when you report an issue. Thanks a lot! :)

Aklapper renamed this task from Error on "undo" screen to Some custom "undo" text on English Wikipedia has line wraps in the middle of words.Apr 2 2018, 7:38 AM
Aklapper renamed this task from Some custom "undo" text on English Wikipedia has line wraps in the middle of words to Some custom "undo" text on English Wikipedia has line breaks in the middle of words.