Page MenuHomePhabricator

Long-lived cherry-picks on deployment-puppetmaster02.deployment-prep.eqiad.wmflabs
Closed, DeclinedPublic

Description

While not super high priority (right?) we should maybe try to resolve the shinken complaining of long-lived cherry-picks on the puppetmaster02 for the deployment-prep instance: CRITICAL: deployment-puppetmaster02/Long lived cherry-picks on puppetmaster as it causes CRITICAL: 100.00% of data above the critical threshold [0.0]. Thanks.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 3 2018, 1:08 PM
EddieGP renamed this task from Long-lived cherry-picks on deployment-puppetmaster02.deployment-prep.equiad.wmflabs to Long-lived cherry-picks on deployment-puppetmaster02.deployment-prep.eqiad.wmflabs.Apr 4 2018, 5:08 PM

That check is a joke. It's there because we don't want long-lived cherry-picks on the puppetmaster. But there's no process to replace the current one of cherry-picking things. So just ignore it for now. We can probably close this task as a duplicate of T135427.

Maybe reset and repull everything or there are changes that were directly done on the puppetmaster and not via gerrit?

The check asks "Is the average number of cherry-picks on the puppet master in the last 48h greater than 0?" If the answer is yes, it goes CRITICAL. The only way to silence it is dropping all the cherry-picks (and leaving them dropped), which is currently not an option. (Or killing the test, which also doesn't seem like a good idea).

EddieGP closed this task as Declined.Apr 13 2018, 11:04 PM

wontfix until T135427: Beta puppetmaster cherry-pick process. We did, do and will just ignore that check, or drop it if it's too annoying,