[regression - wmf.28] The bookmark icon for Saved filters is missing
Closed, ResolvedPublic

Description

On testwiki (and betlabs) Recent Changes page (and other pages with the filters) is missing the bookmark icon - oo-ui-iconElement-icon oo-ui-icon-unClip:

UBN because filters cannot be saved, although the functionality is in place: the place for the icon can be clicked.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 3 2018, 10:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Etonkovidova triaged this task as Unbreak Now! priority.Apr 3 2018, 10:33 PM
Etonkovidova updated the task description. (Show Details)
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptApr 3 2018, 10:33 PM

@Volker_E .... could this have to do with the OOUI icon changes?

@Mooeypoo Yes, it does. We've already got a fix in OOUI dating back a bit.

Caused by c103e8e62aaedf240bb83ca6858568a720140752 I think, but I don't understand why it's not loading.

Change 424021 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@wmf/1.31.0-wmf.28] Revert "RCFilters: Rename deprecated 'unClip' icon to 'bookmark'"

https://gerrit.wikimedia.org/r/424021

Change 424021 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.28] Revert "RCFilters: Rename deprecated 'unClip' icon to 'bookmark'"

https://gerrit.wikimedia.org/r/424021

Mentioned in SAL (#wikimedia-operations) [2018-04-04T23:36:45Z] <catrope@tin> Synchronized php-1.31.0-wmf.28/resources/src/mediawiki.rcfilters/: Fix missing bookmark icon (T191366) (duration: 01m 16s)

Etonkovidova closed this task as Resolved.Apr 4 2018, 11:39 PM
Etonkovidova claimed this task.

Checked in cawiki/hewiki (wmf.28) - the icon is in place and works as expected.

Restricted Application added a project: Growth-Team. · View Herald TranscriptAug 14 2018, 1:14 AM