Page MenuHomePhabricator

Undefined variable: mode in extensions/AbuseFilter/includes/AbuseFilter.php on line 491
Closed, ResolvedPublic

Description

Error Message

  • Notice: Undefined variable: mode in /srv/mediawiki/php-1.31.0-wmf.28/extensions/AbuseFilter/includes/AbuseFilter.php on line 491
  • Notice: Undefined variable: mode in /srv/mediawiki/php-1.31.0-wmf.28/extensions/AbuseFilter/includes/AbuseFilter.php on line 529

Stack Trace

N/A

Notes

Maybe related:

Warning: checkAllFilters() expects exactly 4 parameters, 1 given in /srv/mediawiki/php-1.31.0-wmf.28/extensions/AbuseFilter/includes/AbuseFilter.php on line 471

Event Timeline

mmodell created this task.Apr 4 2018, 8:30 PM
Restricted Application added subscribers: Scoopfinder, Aklapper. · View Herald TranscriptApr 4 2018, 8:30 PM
mmodell updated the task description. (Show Details)Apr 4 2018, 8:31 PM
Nirmos added a subscriber: Daimona.Apr 4 2018, 8:32 PM
Nirmos added a subscriber: Nirmos.Apr 4 2018, 8:35 PM

I think it's because of @Daimona's attempt at making AbuseFilter work with https://www.mediawiki.org/wiki/Optimistic_save to solve T176291 et al.

@Nirmos yes and no :-) It is indeed my fault, but not related to that one. The relevant commit is https://gerrit.wikimedia.org/r/#/c/422953/. I think the trouble is here. Setting $mode as optional parameter should fix this. I'll fix it in a minute, please let me know if that works.

Change 424142 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Make $mode optional for checkAllFilters

https://gerrit.wikimedia.org/r/424142

Change 424142 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Make $mode optional for checkAllFilters

https://gerrit.wikimedia.org/r/424142

Change 424204 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@wmf/1.31.0-wmf.28] Make $mode optional for checkAllFilters

https://gerrit.wikimedia.org/r/424204

@mmodell Do you confirm the problem is solved? The backport is scheduled for today's SWAT.

Change 424204 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@wmf/1.31.0-wmf.28] Make $mode optional for checkAllFilters

https://gerrit.wikimedia.org/r/424204

Mentioned in SAL (#wikimedia-operations) [2018-04-05T13:32:21Z] <zfilipin@tin> Synchronized php-1.31.0-wmf.28/extensions/AbuseFilter: SWAT: [[gerrit:424204|Make $mode optional for checkAllFilters (T191468)]] (duration: 01m 20s)

Daimona closed this task as Resolved.Apr 6 2018, 8:09 AM
Daimona claimed this task.