Page MenuHomePhabricator

Special:MobileLanguages tweaks (label and margin)
Closed, ResolvedPublic2 Story Points

Description

Hi, I am reporting this bug for another user who found out that Special:MobileLanguages (the page you reach when you look for the article in other languages on your mobile device) claims that the given article is available in x languages but it forgets to count in the article from where you are coming from (e.g., opening an article on German Wikipedia that is also available on French and English Wikipedia claiming that this article exists in 2 languages). He suggests two possible fixes, either saying “available in x <more> languages” (my preferred way) or “available in x languages” (which may lead to confusion in the given example with two lines where this article also exists while the page tells us that the article is available in “3” languages). As this is a general bug, we were suggested not to reach out for community consensus what to do.

https://en.m.wikipedia.org/wiki/Special:MobileLanguages/Billericay

Misalignment

There is a misalignment on this page
Actual:


Expected:

Acceptance criteria

  • Text "Billericay is available in 20 languages." should be replaced with "Billericay is available in 20 other languages."
  • Change the label of "Billericay - Languages" to "Billericay - Other Languages"
  • Remove the wrapping class="content " to fix the alignment issue
  • Reposition languages count in the overlay, cf. T191562#4117933

QA instructions

Make sure it's 1pm PST 20th Feb to give time for this change to be live in production.

Compare the language overlay on beta cluster and production:
https://en.m.wikipedia.beta.wmflabs.org/wiki/Barack%20Obama#/languages
https://en.m.wikipedia.org/wiki/Barack%20Obama#/languages
Other languages header should have changed.

Compare alignment of https://en.m.wikipedia.org/wiki/Special:MobileLanguages/Barack_Obama with https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileLanguages/Barack_Obama
In latter title should align with content.

QA Results

Test/ACStatusDetails
Overlay✅ PassedT191562#4970692
Alignment✅ PassedT191562#4970692

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterFix alignment and reposition languages count in Special:MobileLanguages
mediawiki/extensions/MobileFrontend : masterTweak Special:MobileLanguages labels

Event Timeline

DerHexer created this task.Apr 5 2018, 8:17 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 5 2018, 8:17 PM
Jhernandez moved this task from Needs triage to Triaged on the Mobile board.Apr 9 2018, 11:01 AM
ovasileva triaged this task as Normal priority.Apr 9 2018, 11:46 AM
ovasileva added subscribers: alexhollender, ovasileva.

@alexhollender - thoughts? My preference is also "available in x more languages"

DerHexer updated the task description. (Show Details)Apr 9 2018, 12:47 PM

@DerHexer can you please clarify the flow you're following to get to this bug? I'm not sure if you're referring to this page (https://en.m.wikipedia.org/wiki/Lesser_Antillean_macaw#/languages) or something else

@alexhollender when you click on the link without JavaScript (or via right click) you are taken to https://en.m.wikipedia.org/wiki/Special:MobileLanguages/Lesser_Antillean_macaw instead.

@ovasileva here is what iOS does "...available in 12 other languages" (we should make sure to special case for the situation where there is only one other language, to make sure to remove the "s" at the end of "languages", or else it will read "...available in 1 other languages").

Follow up questions:

  1. I wonder if we should also update the copy on the languages overlay panel (see attached jpg below)
  2. Seems like a separate issue of whether or not to include the current language in that list. Pau said the language team is looking into this

as part of the work on Compact Language links, Amir is analyzing the failed searches for a language, and I think it is not uncommon for people to not find a language because that is the current language they are already in. We are not sure whether this is due to muscle memory, or because Google often shows results for different languages in different order.

Follow up questions:

  1. I wonder if we should also update the copy on the languages overlay panel (see attached jpg below)

I agree. I like the alternative version

Follow up questions:

  1. I wonder if we should also update the copy on the languages overlay panel (see attached jpg below)

I agree. I like the alternative version

Me too.

What's the state of this task @alexhollender ?

@alexhollender seems like with your input above we can at least update the overlay title pretty easily! Should we split out a task for that?

@Jdlrobson I think this is ready to go. Going to move it out of design.

alexhollender updated the task description. (Show Details)Dec 7 2018, 3:58 PM
Jdlrobson renamed this task from Special:MobileLanguages shows an incorrect number of language versions to Special:MobileLanguages tweaks (label and margin).Dec 11 2018, 5:56 PM
Jdlrobson updated the task description. (Show Details)

@alexhollender lemme know if the updated description doesn't make sense!

Jdlrobson updated the task description. (Show Details)Jan 16 2019, 5:28 PM
ovasileva updated the task description. (Show Details)Jan 16 2019, 5:29 PM
ovasileva set the point value for this task to 2.

Change 485955 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/extensions/MobileFrontend@master] Tweaking Special:MobileLanguages labels and margin

https://gerrit.wikimedia.org/r/485955

Ammarpad updated the task description. (Show Details)Jan 23 2019, 7:49 PM

Change 485955 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Tweak Special:MobileLanguages labels

https://gerrit.wikimedia.org/r/485955

Jdlrobson added a comment.EditedFeb 1 2019, 5:01 AM

@Ammarpad have you hit problems with the CSS part of this task? If so please let me know how i can help you!

@Ammarpad have you hit problems with the CSS part of this task? If so please let me know how i can help you!

Thanks, @Jdlrobson. I will upload new patch for that. Actually your last comment in the last patch put me on hold, I thought you wanted to remove something first.

Actually your last comment in the last patch put me on hold, I thought you wanted to remove something first.

😬 Sorry for the confusion! Looks like my English could have been better there. I can confirm that I'm not removing anything myself. Please continue and let me know if/how I can help you :)

Change 489467 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/extensions/MobileFrontend@master] Fixes in Special:MobileLanguages

https://gerrit.wikimedia.org/r/489467

Jdlrobson updated the task description. (Show Details)Feb 11 2019, 6:30 PM

Hi @Ammarpad ! Here's some feedback on this patch. I've updated the task as sadly it was not as clear as it could have been. To be clear, the language overlay is behaving correctly and we don't want to make changes to it.

The change changes the styling of the language overlay and moves the number "223" to the left like so:

beforeafter

However, we want to fix the alignment in the language page at https://en.m.wikipedia.org/wiki/Special:MobileLanguages/Billericay. The overlay https://en.m.wikipedia.org/wiki/Billericay#/languages is behaving and appearing as expected.

The Special:MobileLanguages page does not use these styles. The fix should also not require any CSS changes, just some changes to includes/specials/SpecialMobileLanguages.php

Hi @Ammarpad ! Here's some feedback on this patch. I've updated the task as sadly it was not as clear as it could have been. To be clear, the language overlay is behaving correctly and we don't want to make changes to it.
The change changes the styling of the language overlay and moves the number "223" to the left like so:

beforeafter

However, we want to fix the alignment in the language page at https://en.m.wikipedia.org/wiki/Special:MobileLanguages/Billericay. The overlay https://en.m.wikipedia.org/wiki/Billericay#/languages is behaving and appearing as expected.
The Special:MobileLanguages page does not use these styles. The fix should also not require any CSS changes, just some changes to includes/specials/SpecialMobileLanguages.php

Thanks @Jdlrobson. But I intentionally did that because of @alexhollender's suggestion in T191562#4117933, I thought it was OK. Now it can be dropped.

@alexhollender we've got a patch. Please confirm this matches your mocks and I'll merge:




Hebrew:

Ammarpad updated the task description. (Show Details)Feb 16 2019, 7:50 AM

Change 489467 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Fix alignment and reposition languages count in Special:MobileLanguages

https://gerrit.wikimedia.org/r/489467

Jdlrobson reassigned this task from Jdlrobson to Edtadros.Feb 20 2019, 8:09 PM
Jdlrobson updated the task description. (Show Details)

Time for some QA. This change should be live shortly so allow at least till 12.30pst.

Edtadros added a comment.EditedFeb 21 2019, 5:44 AM

Test Results

OS: macOS Mojave
Browser: Chrome DevTools Device Emulator (iPhone X)

Test Artifact(s):

Language Overlay

Status: ✅ Pass

https://en.m.wikipedia.beta.wmflabs.org/wiki/Barack_Obama#/languages

https://en.m.wikipedia.org/wiki/Barack_Obama#/languages

Alignment

Status: ✅ Pass

  • I'm not sure what an acceptable threshold is. The text is aligned, give or take a pixel, but the bullet is not. If these are all acceptable I can change this to Pass.

Per T191562#4973148 the alignment in the image below is unrelated.

https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileLanguages/Barack_Obama

Edtadros updated the task description. (Show Details)Feb 21 2019, 5:48 AM
Edtadros reassigned this task from Edtadros to Jdlrobson.Feb 21 2019, 5:50 AM
Edtadros added a subscriber: Edtadros.

@Jdlrobson This could be a pass depending on how particular you want to be with regards to alignment.

I don't believe the pixel-issue mentioned in T191562#4970692 is related to this task. I say we're good to go here.

Edtadros reassigned this task from Edtadros to ovasileva.Feb 21 2019, 9:40 PM
Edtadros updated the task description. (Show Details)

Thanks for the clarification, @Jdlrobson and @alexhollender.

ovasileva closed this task as Resolved.Feb 22 2019, 8:54 AM