Page MenuHomePhabricator

In StructuredDiscussions, keep the toolbar visible when scrolling
Closed, DeclinedPublic

Description

keep the StructuredDiscussions toobar visible when scrolling.

  • Current CSS on StructuredDiscussions is already halfway there: the left side of the toolbar is already fixed. Fixing the right side of the toolbar is logical completion of current behavior.
  • enables user to access to the toolbar, and open the notification menu, without losing scroll position.
  • functionally, it makes sense. The toolbar functionality 'scope' is the whole page, not just the top of the page. The toolbar is meta.
#p-personal{
    position:fixed;
    background: rgb(255,255,255);
}

Event Timeline

Johnywhy created this task.Apr 5 2018, 10:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 5 2018, 10:45 PM

Current CSS on mediawiki.org is already halfway there: the left side of the toolbar is already fixed. Fixing the right side of the toolbar is logical completion of current behavior.

I don't see this. Can you provide a screenshot? (Are you using a different skin than Vector?)

It looks like this for me (this is the main page, scrolled all the way down) – the menus are not fixed:


I'm not sure if this is the right functionality for the default Vector skin. If you're logged in, you can choose a different one in Preferences, for example Timeless, which has a fixed header:

This is relevant to support desktop page

Cannot reproduce, not fixed on https://www.mediawiki.org/wiki/Project:Support_desk (if that is what you mean by "support desktop page"; full links always welcome to avoid misunderstandings).

See previous (unanswered) question: Are you using a different skin than Vector?
Also, is this still fixed on https://www.mediawiki.org/wiki/Project:Support_desk?safemode=1 for you?

Aklapper triaged this task as Lowest priority.Apr 10 2018, 9:39 AM

Nobody here can see or confirm that "Current CSS on mediawiki.org is already halfway there: the left side of the toolbar is already fixed."
The question is not whether your CSS works. The question is why you think that the left side of the toolbar is already fixed. For Matma and me it is not.

Plus there are already skins which offer this...

I guess this is about Flow specifically, and the floating topic title:

matmarex removed a subscriber: matmarex.Apr 10 2018, 7:08 PM
Johnywhy added a comment.EditedApr 11 2018, 3:46 AM

Nobody here can see or confirm that "Current CSS on mediawiki.org is already halfway there: the left side of the toolbar is already fixed."

@matmarex is correct. I'm referring to the support desk. Sorry if i didn't make that clear.

Here's the support desk with the default mediawiki.org skin and default mediawiki.org CSS, showing a fixed left-hand toobar.

This might be more appropriate as a feature in Extension:StructuredDiscussions.

Johnywhy renamed this task from Keep the MediaWiki.org toolbar on the top visible when scrolling down to In StructuredDiscussions, keep the toolbar visible when scrolling.Apr 11 2018, 3:47 AM
Johnywhy added a subscriber: matmarex.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 11 2018, 3:48 AM
Johnywhy updated the task description. (Show Details)Apr 11 2018, 3:50 AM

enables user to access to the toolbar, and open the notification menu, without losing scroll position.

I am missing a use case why you need to open the notification menu so often that it would be justified to squeeze that menu in. Could you elaborate?

matmarex removed a subscriber: matmarex.Apr 12 2018, 3:00 PM
Aklapper closed this task as Declined.Aug 4 2018, 3:33 PM

Unfortunately closing this report as no further information has been provided.

After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!

Restricted Application added a project: Growth-Team. · View Herald TranscriptAug 4 2018, 3:33 PM

Exactly how often do you consider often enough?
Do you understand the importance of consistent headers? Currently, they are not consistent.