Page MenuHomePhabricator

Ensure compatibility with the metadata gadget (which displays an article assessment not shown in Timeless)
Closed, ResolvedPublic

Description

Hello,
I would like to know how to unhide the Wikipedia message that was below the title (an article from Wikipedia the free encyclopedia) because the metadata gadget (https://en.wikipedia.org/wiki/Wikipedia:Metadata_gadget) needs it to display the article's assessment without opening the edit page.
Thanks for the help

Event Timeline

Hi @Gokudera_ElPsyCongroo, thanks for taking the time to report this and welcome to Phabricator.

Which "Wikipedia message" do you refer to exactly? Some banner? Something else?
Is this problem specific to the Timeless skin (as that is the project tag of this task)? Can you unhide that message in other skins?
What is an "article's assessment"?

Please also see https://www.mediawiki.org/wiki/How_to_report_a_bug how to preferably structure tasks - thanks a lot!

Hello,

Thank you for your answer and sorry for my lack of precision.

--Terms explanation--
Below every article's title on default Wikipedia, there is a statement : "From Wikipedia the free encyclopedia". The metadata gadget (https://en.wikipedia.org/wiki/Wikipedia:Metadata_gadget) modifies that statement to display the corresponding article's assessment. An article's assessment on Wikipedia is it's rating. They include "Featured" or "Good" articles for exemple. More info there (https://en.wikipedia.org/wiki/Wikipedia:WikiProject_Wikipedia/Assessment).
So, when using the metadata gadget on a Featured Article, the message "from Wikipedia the free encyclopedia" will change into : "A Featured Article from Wikipedia the free encyclopedia". It permits to know an article's assessment without having to check for it.

--Actual results--
But unfortunately the Timeless skin, which I especially love for its responsiveness, hides or deletes that statement.

  1. So when I load a Wikipedia page,
  2. look for the statement
  3. I can't see it's assessment, since the statement disappeared.

Thus I can't use the metadata gadget anymore.

When I switch to several other skins that chooses not to hide that statement, the metadata gadget works just fine. But it doesn't work in skins that hides the statement. So the solution is to unhide it, but I don't know how to do it.
In CSS, the statement's id is "#siteSub".

--Expected results--
I would like to :

  1. Load a Wikipedia page with the Timeless skin, for example a featured article;
  2. See, below the title, the statement "From wikipedia, the free encyclopedia";
  3. See it change into "A Featured article from wikipedia, the free encyclopedia", using the metadata gadget.

I use Chrome on Windows and Android.
Thank you for the help, and sorry for my English, I am French !

Aklapper renamed this task from Ensure compatibility with the metadata gadget to Ensure compatibility with the metadata gadget (which displays an article assessment not shown in Timeless).Apr 8 2018, 12:35 PM

Thanks a lot for the great explanation!

Evad37 added a subscriber: Evad37.Apr 28 2018, 12:55 AM

@Gokudera_ElPsyCongroo I've created a workaround until the issue is fixed in the skin: Add
importScript('User:Evad37/Metadata-timeless.js') // [[User:Evad37/Metadata-timeless.js]]
to your timeless.js (which you'll probably have to create, unless you've used it before)

Thank you very much, the fix works very well

Evad37 closed this task as Resolved.Aug 3 2018, 5:07 AM
Evad37 claimed this task.

Resolved due to T193215 being resolved.