Page MenuHomePhabricator

PageCuration tool error: failed to apply tags to the page but still marks as reviewed
Closed, InvalidPublic

Description

PageCuration sometimes fails to tag articles, with the popup message "failed to apply tags to the page".
However in cases of failure it still marks the pages as reviewed, and (if applicable) still creates the AfD page.

A few reports of this bug from various editors at https://en.wikipedia.org/wiki/Wikipedia_talk:New_pages_patrol/Reviewers#curation_tool_error:_failed_to_apply_tags_the_page

Event Timeline

Quiddity created this task.Apr 6 2018, 6:52 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 6 2018, 6:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Kudpung added a subscriber: Kudpung.Apr 6 2018, 7:18 PM

Experienced this bug myself.

kaldari added a subscriber: kaldari.Apr 6 2018, 8:04 PM

I was not able to reproduce this bug (in Firefox). I tried several different sequences of tagging and reviewing (with different tags) and wasn't able to get the error. Reliable reproduction steps are needed.

One of the reporters was using Chrome. That's the only browser data we have so far.

The error message being displayed in the UI comes from modules/ext.pageTriage.views.toolbar/ext.pageTriage.delete.js, line 767.

Etonkovidova added a subscriber: Etonkovidova.EditedApr 11 2018, 9:39 PM

I saw that articles mentioned on https://en.wikipedia.org/wiki/Wikipedia_talk:New_pages_patrol/Reviewers#curation_tool_error:_failed_to_apply_tags_the_page e.g. Dilip De, Dilip K De, and Miltiadis Karatzis were eventually deleted and marked with the tags mentioned.

The issue is not possible to reproduce in betalabs:
Applying tags from 'Speedy deletion' - no warning ("failed to apply tags to the page") is displayed. Non-existing in betalabs template will be added to the page. The page itself will be displayed as Reviewed on Special:NewPagesFeed, and not with the trashbin icon as in enwiki.

jmatazzoni closed this task as Invalid.Apr 25 2018, 3:22 PM
jmatazzoni added a subscriber: jmatazzoni.

Closing, since we can't reproduce. We can open again if someone sees it again...