Page MenuHomePhabricator

Enable $wgCookieSetOnIpBlock by default after the IP cookie block feature is fully tested and released
Closed, ResolvedPublic

Description

I don't see a valid reason why T152462: Add cookie when blocking anonymous users shouldn't be enabled by default for all wikis after the initial roll-out and that we know it works as intended.

$wgCookieSetOnIpBlock should be set to true by default.
$wgCookieSetOnAutoblock looks like another good candidate to enable by default.

Event Timeline

dmaza created this task.Apr 10 2018, 9:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2018, 9:28 PM
Krinkle added a subscriber: Krinkle.EditedApr 11 2018, 1:40 AM

Usually, when a task says "enable for all wikis by default", that does not relates to enabling settings in MediaWiki core. Rather, it usually means:

wmf-config/InitialiseSettings.php
   'wgUseTheFeature' => [
+    'default' => true,
-    'default' => false,
-  
-    // group0
-    'testwiki' => true,
-    'test2wiki' => true,
-    'mediawikiwiki' => true,
-  
-    // Opt-in wikis
-    'nlwiki' => true,
-    'commonswiki' => true,
-    'metawiki' => true,
-  
-    // Wiki families
-    'wiktionary' => true,
-    'wikipedia' => true,
   ],

Anyhow, I've tagged it with MW-1.32-release so that we'll remember before November 2018 to evaluate and whether to enable it for this or a later release.

Krinkle changed the task status from Open to Stalled.Apr 11 2018, 1:41 AM
Krinkle triaged this task as Medium priority.
Krinkle added a project: MW-1.32-release.
dmaza added a comment.Apr 11 2018, 7:59 PM

I think the whole "conundrum" was weather to have this feature enabled by default in core or not. Basically, why enable by a config patch when this should(?) be a standard feature on core.

dmaza renamed this task from Enable $wgCookieSetOnIpBlock by default after the IP cookie block feature is fully tested and released to Enable $wgEnableAutoblockForIpBlocks by default after the IP cookie block feature is fully tested and released.Apr 20 2018, 6:05 PM
dmaza updated the task description. (Show Details)
dmaza renamed this task from Enable $wgEnableAutoblockForIpBlocks by default after the IP cookie block feature is fully tested and released to Enable $wgCookieSetOnIpBlock by default after the IP cookie block feature is fully tested and released.Jun 1 2018, 1:04 AM
dmaza updated the task description. (Show Details)
Legoktm changed the task status from Stalled to Open.Aug 28 2018, 8:40 PM
Legoktm added a subscriber: Legoktm.

Un-stalling, it's been about a month after deploying to Wikimedia sites. Should we flip the MediaWiki defaults now?

dmaza added a comment.Aug 29 2018, 2:18 AM

Maybe it is a good idea to also remove the debug tracking we have in there (?)
https://gerrit.wikimedia.org/r/plugins/gitiles/mediawiki/core/+/master/includes/user/User.php#1407

daniel added a subscriber: daniel.Dec 17 2018, 1:01 PM

Let's do it.

Uh, right. Who is doing it?

dmaza added a comment.Dec 17 2018, 5:53 PM

Let's do it.

Uh, right. Who is doing it?

Removing the tracking (https://gerrit.wikimedia.org/r/plugins/gitiles/mediawiki/core/+/master/includes/user/User.php#1407) or flipping the switch?
I can do both

Reedy added a subscriber: Reedy.Jun 7 2019, 10:55 PM

1.33.0-rc.0 has sailed... If we want this in 1.33 (and as such 1.33.0-rc.1), patches would be welcome soon...

This missed the boat for the MW 1.33 release. Provisionally re-tagging to 1.34's release instead.

Hey there, should this be moved to 1.35? The cut is a couple of weeks away. If it needs to go out in 1.34, is there anything I can do to help get it out of the door?

Change 534690 had a related patch set uploaded (by Dmaza; owner: Dmaza):
[mediawiki/core@master] Enable $wgCookieSetOnAutoblock and $wgCookieSetOnIpBlock by default

https://gerrit.wikimedia.org/r/534690

dmaza added a comment.Sep 5 2019, 9:50 PM

@Jdforrester-WMF Since CommonSettings is currently setting these two configs to true there shouldn't be any problems I assume.

The next step would be to remove it from mediawiki-config. I could also do that after this gets deployed if you want.

Change 534690 merged by jenkins-bot:
[mediawiki/core@master] Enable $wgCookieSetOnAutoblock and $wgCookieSetOnIpBlock by default

https://gerrit.wikimedia.org/r/534690

Jdforrester-WMF closed this task as Resolved.Sep 5 2019, 10:36 PM
Jdforrester-WMF assigned this task to dmaza.

OK, this bit is done. Thank you! I'll do a cleanup patch for after next week's train.

Change 534698 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[operations/mediawiki-config@master] Stop setting wgCookieSetOnAutoBlock and wgCookieSetOnIpBlock to the default; never varied

https://gerrit.wikimedia.org/r/534698

Change 534698 merged by jenkins-bot:
[operations/mediawiki-config@master] Stop setting wgCookieSetOnAutoBlock and wgCookieSetOnIpBlock to the default; never varied

https://gerrit.wikimedia.org/r/534698