Page MenuHomePhabricator

When resolving a topic, clicking on the summary textarea uncollapses and collapses all messages
Closed, ResolvedPublic

Description

How to reproduce:

  1. resolve a topic - all messages are collapsed and are not visible
  2. click in the textarea field

Expectation:

  • nothing moves

Reality:

  • collapsed messages are visible
  • if you click again, they are collapsed again and so on.

Tested on Firefox and Chromium last versions.

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 11 2018, 8:10 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Trizek-WMF updated the task description. (Show Details)Apr 11 2018, 8:11 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 2 2018, 10:10 AM
SBisson added a subscriber: SBisson.

It's the Flow legacy front-end we're talking about.

Change 460100 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/Flow@master] Don't expand/collapse topics when clicking the editor

https://gerrit.wikimedia.org/r/460100

SBisson claimed this task.Sep 12 2018, 8:48 PM
SBisson edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
SBisson moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

I merged the patch, but wanted to note that it feels odd that "Summarize" shows you the list of comments while "Resolve" does not, even though both actions prompt you to add a summary via flow-edit-summary-placeholder. But that's another issue for another day.

Change 460100 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Don't expand/collapse topics when clicking the editor

https://gerrit.wikimedia.org/r/460100

Etonkovidova closed this task as Resolved.Sep 14 2018, 9:54 PM
Etonkovidova added a subscriber: Etonkovidova.

Checked the fix in betalabs.

Checked in testwiki (wmf.22) - the issue is not present.

For comparison - in wmf.20 clicking in Summary will open posts:

Clicked again: