Page MenuHomePhabricator

CodeMirror syntax highlighting shows overlapping text when word-wrap (hyphens, word-break) is overridden
Closed, ResolvedPublic

Description

Someone has reported (in T184467#4124483 and T184467#4105987 and elsewhere in that ticket) that in the 2017 Wikitext editor with CodeMirror enabled the text will display as fuzzy. This appears to be because word-wrap, hyphens, or word-break is overridden in the users's browser.

Details

Related Gerrit Patches:
mediawiki/extensions/CodeMirror : masterMerge selectors for VE & CM surfaces, and add 'hyphens' rule

Event Timeline

Restricted Application added a project: Community-Tech. · View Herald TranscriptApr 11 2018, 7:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Looking at the screenshot, the problem isn't with word-wrap, but with hyphens. So the value should be reset to manual or none, to make it match the overlay (though setting this to auto on editable content seems bad anyway).

Here's another example, from today. I want to challenge the assignment of 'low' priority to this bug. I encounter this error more than half of the time when I edit in Firefox. I'm disabling the 2017 WTE until it's fixed; it basically prevents me from using the feature in my chosen browser, and it's not an edge case. @TBolliger can you give me a sense of why this is being de-prioritized?

TBolliger renamed this task from CodeMirror syntax highlighting shows overlapping text when word-wrap (word-break) is overridden to CodeMirror syntax highlighting shows overlapping text when word-wrap (hyphens, word-break) is overridden.Apr 12 2018, 7:51 PM
TBolliger raised the priority of this task from Low to Medium.
TBolliger updated the task description. (Show Details)
TBolliger added a subscriber: Esanders.

We only received one report of this hyphenation defect and were not able to reproduce on the same browser/OS combination, thus the lower priority.

@Esanders — Any thoughts on @Schnark's comments in T192019#4126302 ?

Restricted Application added a project: VisualEditor. · View Herald TranscriptApr 12 2018, 7:53 PM
matmarex added a subscriber: matmarex.

Seems like an easy fix, similar to this commit we merged today: https://gerrit.wikimedia.org/r/#/c/422346/

Change 426949 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/CodeMirror@master] Merge selectors for VE & CM surfaces, and add 'hyphens' rule

https://gerrit.wikimedia.org/r/426949

Change 426949 merged by jenkins-bot:
[mediawiki/extensions/CodeMirror@master] Merge selectors for VE & CM surfaces, and add 'hyphens' rule

https://gerrit.wikimedia.org/r/426949

TheDJ added a subscriber: TheDJ.Jun 17 2018, 8:57 PM

So is this fixed now with T192019#4134117 ?

So is this fixed now with T192019#4134117 ?

@Aschmidt reported that it is still not fixed for him.

@matmarex / @Esanders Could one of you look into this? Thank you.

@Aschmidt reported that it is still not fixed for him.

Based on the screenshot in https://de.wikipedia.org/w/index.php?title=Benutzer_Diskussion:Aschmidt&oldid=178336976#Technische_Wünsche:_Wikitext-Syntaxhervorhebung_ist_jetzt_Standardfunktion, that seems like a different issue:

There is no word-wrapping in the screenshot, and that was the cause of this problem.

@Aschmidt If you still see that problem, can you file another task? (yet another…)

matmarex closed this task as Resolved.Aug 10 2018, 12:55 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptAug 10 2018, 12:55 AM