Page MenuHomePhabricator

In IE11, blue buttons at Commons's UploadWizard become label-less after being clicked
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Use Internet Explorer 11 at either Windows 7 or Windows 8.
  2. Go to https://commons.wikimedia.org/wiki/Special:UploadWizard
  3. Click on the "Select media files to share"
  4. Either click "Cancel", or select one of images and then select "Open"
  5. (Optional) Click "Add more files", and repeat step 4

Actual results:

  • Labels disappear from the blue buttons, i.e. blue buttons become label-less. The buttons become labelled again when the page is refreshed/reloaded, but repeating steps produce the same results.

Expected results:

  • At IE11, the blue buttons should remain labelled after being clicked.

Event Timeline

gh87 created this task.Apr 13 2018, 5:08 AM
Restricted Application added a project: Multimedia. · View Herald TranscriptApr 13 2018, 5:08 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
gh87 renamed this task from In IE11, blue buttons at UploadWizard become label-less after being clicked to In IE11, blue buttons at Commons's UploadWizard become label-less after being clicked.Apr 13 2018, 5:18 AM
matmarex claimed this task.Apr 16 2018, 3:39 PM
matmarex added a subscriber: matmarex.

I looked into this because it was amusing. (And because not many other engineers at WMF routinely use Windows.) This also happens in IE11 on Windows 10.

Only the buttons to add files are affected, apparently because of how we customize them to make them display the OS file select dialog.

Change 426950 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/UploadWizard@master] Prevent the file select button label from scrolling offscreen on IE11

https://gerrit.wikimedia.org/r/426950

gh87 added a comment.Apr 16 2018, 6:32 PM

Is OOUI related to this? I see changes were made to modernize the layout. Moreover, I thought about adding the OOUI tag.

No, this problem only affects these two buttons in UploadWizard, all other OOUI buttons everywhere are okay.

Change 426950 merged by Matthias Mullie:
[mediawiki/extensions/UploadWizard@master] Prevent the file select button label from scrolling offscreen on IE11

https://gerrit.wikimedia.org/r/426950

matmarex closed this task as Resolved.Apr 17 2018, 10:31 AM
matmarex removed a project: Patch-For-Review.
gh87 added a comment.Apr 17 2018, 10:30 PM

I still see those blue buttons label-less after clicking them. I'm on IE11 at Windows 7.

@gh87 The change is not yet deployed to production Wikimedia wikis (e.g. Commons, Wikipedia, etc.). I'm sorry I didn't explain this.

You can test the change now on the Beta Cluster: https://commons.wikimedia.beta.wmflabs.org/wiki/Special:UploadWizard (you will need to create a separate account than on the production wikis).

The change is being deployed this week, Tuesday-Thursday, as part of MediaWiki 1.31.0-wmf.30 – it will be deployed to Commons a few hours from now: https://wikitech.wikimedia.org/wiki/Deployments#deploycal-item-20180418T1900. It will be fixed on https://commons.wikimedia.org/wiki/Special:UploadWizard after that happens.

Change 498352 had a related patch set uploaded (by Esanders; owner: Esanders):
[oojs/ui@master] SelectFileInputWidget: Apply IE11 scrolling fix

https://gerrit.wikimedia.org/r/498352

Change 498352 merged by jenkins-bot:
[oojs/ui@master] SelectFileInputWidget: Apply IE11 scrolling fix

https://gerrit.wikimedia.org/r/498352

Change 499353 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Update OOUI to v0.31.2

https://gerrit.wikimedia.org/r/499353

Change 499353 merged by jenkins-bot:
[mediawiki/core@master] Update OOUI to v0.31.2

https://gerrit.wikimedia.org/r/499353