Page MenuHomePhabricator

Flawed mentions in Flow and "wikitext" to "html" conversion exception
Open, Needs TriagePublic

Description

I don't know whether these two phenomena are connected, but as can be seen in the screenshot below, temlpate FlowMention fails to render in StructuredDiscussions when using the visual editor. The template exists.


Moreover, submitting the topic results in:

[ef03f32d18dfe33cc0c48921] Exception caught: Request to parsoid for "wikitext" to "html" conversion of content connected to title "Topc:Ubege0uwo0i7zyng" failed: 406

Is this related to T191215?

I have this in two wikis running MW 1.30, Flow: REL1_30 9193b03, and Parsoid (0.9.0all) jessie-mediawiki 5fe6923ab

Event Timeline

ahmad created this task.Apr 16 2018, 9:06 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 16 2018, 9:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

[ef03f32d18dfe33cc0c48921] Exception caught: Request to parsoid for "wikitext" to "html" conversion of content connected to title "Topc:Ubege0uwo0i7zyng" failed: 406

Please provide a stacktrace: https://www.mediawiki.org/wiki/Manual:How_to_debug

[ef03f32d18dfe33cc0c48921] Exception caught: Request to parsoid for "wikitext" to "html" conversion of content connected to title "Topc:Ubege0uwo0i7zyng" failed: 406

This is the same thing as T191215: corrupted rev_content

Lokal_Profil added a subscriber: Lokal_Profil.

Adding this to the Samsyn board as this also affects our wiki. In our case it is both an issue in VisualEditor and that the name is not displayed when the post is viewed after saving.

Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 6 2018, 9:35 AM

The "failed: 406" error is documented in T191215 and was fixed but I think to get it you either have to upgrade MW/Flow to 1.31 or downgrade Parsoid to 0.8.0.

SBisson closed this task as Resolved.Sep 7 2018, 6:17 PM
SBisson claimed this task.

Closing per the above comment. The error is fixed but you need to upgrade or downgrade to a supported combination.

Lokal_Profil reopened this task as Open.EditedSep 14 2018, 1:45 PM

Re-opening as we are still experiencing this issue on another wiki with the version combination MediaWiki 1.31.0, Flow REL1_31 and Parsoid 0.9.0.

The template exists and notifications are triggered.

View during (VE) editing

View when viewing after saving:

What is the meaning of those messages, @Lokal_Profil.

What is the meaning of those messages, @Lokal_Profil.

The images?
The first illustrates that the FlowMention template does not get rendered when viewing the message in VE during editing (by comparison on e.g. se.wikimedia.org the view would be "@mentioned_user").
The second illustrates that the FlowMention template does not get rendered when viewing the message (outside of editing).

The template exists and contains the same same wikitext as e.g. wmse:Template:FlowMention. When I view "what links here" for the template nothing shows up. The mention triggers a notification to the mentioned user so it is a rendering issue in SturcturedDiscussions.

Re-opening as we are still experiencing this issue on another wiki with the version combination MediaWiki 1.31.0, Flow REL1_31 and Parsoid 0.9.0.

With this combination you should NOT see Exception caught: Request to parsoid for "wikitext" to "html" conversion of content connected to title "Topc:xxx" failed: 406 anymore. Can you confirm this?

Are you seeing any other error in the log that could be related to Flow or Parsoid?

SBisson removed SBisson as the assignee of this task.Sep 19 2018, 3:39 PM

Re-opening as we are still experiencing this issue on another wiki with the version combination MediaWiki 1.31.0, Flow REL1_31 and Parsoid 0.9.0.

With this combination you should NOT see Exception caught: Request to parsoid for "wikitext" to "html" conversion of content connected to title "Topc:xxx" failed: 406 anymore. Can you confirm this?

Are you seeing any other error in the log that could be related to Flow or Parsoid?

True that I don't get that error. The behaviour I see is the same as in the screenshot in the task description though.

Running it with ?debug=1 I get the following in the (Firefox) console during editing:
unreachable code after return statement[Learn More] flow-board-loadmore.js:482:3
and get the attached Flow debug.

When saving I get the following in the console:

mw.Api error: http
{…}
exception: ""
textStatus: "error"
xhr: Object { readyState: 0, getResponseHeader: getResponseHeader(), getAllResponseHeaders: getAllResponseHeaders(), … }
<prototype>: {…}

the wiki is closed but I'll happily try any necessary debug tricks.

Most likely, the rendering problems in edit mode and in view mode have the same root cause: Parsoid is not able to render the mention template.

I think you might need to set $wgVirtualRestConfig['modules']['parsoid']['forwardCookies'] = true; . If that doesn't work, try $wgFlowParsoidForwardCookies = true;.

ahmad added a subscriber: Uwe_a.Oct 2 2018, 10:24 AM

Most likely, the rendering problems in edit mode and in view mode have the same root cause: Parsoid is not able to render the mention template.

I think you might need to set $wgVirtualRestConfig['modules']['parsoid']['forwardCookies'] = true; . If that doesn't work, try $wgFlowParsoidForwardCookies = true;.

Thanks we'll give them a try and report back here.

@Catrope We tried the above but no luck. We also have $wgSessionsInObjectCache=true so that isn't the cause either.

Hello,

Do you fix this error?

I am having this problem exactly like yours.

MediaWiki 1.32.0
PHP 7.3.6 (apache2handler)
MariaDB 5.5.60-MariaDB
ICU 62.1

@Aklapper

HI, I end up with changing parsoid back to 0.9.0 and adding ParsoidConfig.prototype.strictAcceptCheck = false

Do you know that is this a bug or something?

Thanks