Slow search on apps
Closed, ResolvedPublic

Description

The speed to launch search results is extremely laggy. Many many third party clients are able to launch the same information much quicker.
https://ticket.wikimedia.org/otrs/index.pl?Action=AgentTicketZoom;TicketID=10666969#12661415

Other tickets for both iOS and Android have reported this slowness for search.

LGoto created this task.Apr 18 2018, 9:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 18 2018, 9:08 PM

Cannot reproduce.

JMinor triaged this task as Normal priority.May 8 2018, 2:13 AM

Investigate if there's a debounce delay on type and perhaps move to searching immediately and only showing if the results match the current search string.

Dbrant added a subscriber: Dbrant.May 10 2018, 8:54 PM

related ticket in Android: T190082

Mhurd added a comment.May 15 2018, 6:40 PM

Testing criteria

  • please run any tests associated with searching for articles
ABorbaWMF added a subscriber: ABorbaWMF.

I did a fair amount of search testing on 5.8.2 (1408) and (1409) and did not notice any slowness.

JMinor closed this task as Resolved.Jun 21 2018, 9:51 PM