Page MenuHomePhabricator

Special:GlobalUserRights does not have a value in username field when access /USERNAME
Closed, ResolvedPublic

Description

Steps to Reproduce:

Actual Results:

  • Does not have a value in username field

Expected Results:

Event Timeline

Rxy created this task.Apr 21 2018, 8:48 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 21 2018, 8:48 AM
Rxy updated the task description. (Show Details)Apr 21 2018, 8:57 AM

How you get this? means If I am a simple user then I will simply go Special:GlobalUserRights and then just type the username. and got Special:GlobalUserRights?user=rxy like url. So where you get Special:GlobalUserRights/$par?

Reedy triaged this task as Low priority.Apr 21 2018, 10:15 AM
Reedy added a subscriber: Reedy.

How you get this? means If I am a simple user then I will simply go Special:GlobalUserRights and then just type the username. and got Special:GlobalUserRights?user=rxy like url. So where you get Special:GlobalUserRights/$par?

Typing it manually, probably. Because we do this in various places for ease (typing /foo is easier than ?user=foo)

The code seems to work, just doesn't always populate the text box. Should be trivial enough to fix though

The code seems to work, just doesn't always populate the text box [...]

That.

I know what the problem is

Restricted Application added a project: User-Jayprakash12345. · View Herald TranscriptApr 21 2018, 10:45 AM

Change 428050 had a related patch set uploaded (by Jayprakash12345; owner: Jayprakash12345):
[mediawiki/extensions/CentralAuth@master] Use 'default' instead of 'value'

https://gerrit.wikimedia.org/r/428050

Jayprakash12345 closed this task as Resolved.Apr 25 2018, 2:41 PM
Jayprakash12345 removed a project: Patch-For-Review.
Jayprakash12345 removed a subscriber: gerritbot.
Jayprakash12345 reopened this task as Open.Apr 25 2018, 2:47 PM

Change 428050 merged by jenkins-bot:
[mediawiki/extensions/CentralAuth@master] Use 'default' instead of 'value'

https://gerrit.wikimedia.org/r/428050

Jayprakash12345 closed this task as Resolved.Apr 25 2018, 5:11 PM