Page MenuHomePhabricator

[Feedback] Personal observations about the page previews feature usability
Closed, ResolvedPublic

Description

I like the page-previews extension. This is a non-actionable comment on the feature. Please close me once you have read it and only if you agree some of these are reasonable, I can file more detailed, individual, feature-request tasks. Hope this is useful.

  • The "gear" icon on the preview panel links to https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-rendering For me this is highly confusing, I think it should link to id #mw-prefsection-rendering-reading so the enable/disable preferences are on top.
  • I love the behaviour of the panel, most of these dynamic elements are usually annoying, but I think I never was given an action I didn't want to perform. I am worried if people with limited mobility (disabilities, elder people, etc.) will have issues with it, and if it would be nice to allow optionally for a "slower" mode (where panel takes more time to disappear/mouse can be moved with even less precision). I love that it works without a mouse.
  • This is not technically a page-preview thing, but a summary generation one. https://www.mediawiki.org/wiki/Page_Previews/Functionality#Basic_Functionality is a bit hidden, it would be nice that end-user documentation would be linked easier. I predict a lot of people asking "why is my text/image not showing". Maybe that bit can be copied into the 'Help:' namespace on Wikipedia. I wonder also if Wikidata could be used to decide an image in case of conflict?
  • Could the feature be enabled at other projects on links towards wikipedias (e.g. Wikidata, but only for interwiki links, wikivoyage, but only for [[w: ]] links, etc.? That should be easier than making summaries work for other types of content (I am just guessing)?
  • I feel the area that is clickable on the panel is strange- I guess it is only on the part that is 100% visible, and that a gap has to be added between the preferences and the button, but maybe the gap can be just a corner on the right-down, or at least extend the clickable parts a bit more towards the bottom part? Image attached:

Event Timeline

jcrespo created this task.Apr 21 2018, 11:07 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 21 2018, 11:07 AM
jcrespo renamed this task from [Feedback] Personal observations about the page previews feature usuability to [Feedback] Personal observations about the page previews feature usability.Apr 21 2018, 11:14 AM
jcrespo updated the task description. (Show Details)
Jhernandez added subscribers: ovasileva, Jhernandez.

Thanks for your thoughts @jcrespo!

Makes sense. I've created T192772: Settings cog should use modal used for anonymous users to track it

  • I feel the area that is clickable on the panel is strange- I guess it is only on the part that is 100% visible, and that a gap has to be added between the preferences and the button, but maybe the gap can be just a corner on the right-down, or at least extend the clickable parts a bit more towards the bottom part? Image attached:

This definitely looks like a bug. I've reproduced myself with today's https://es.wikipedia.org/wiki/Wikipedia:Portada hovering on historia del chocolate. It seems like the clickable area is not appropriately shaped.

I've created T192773: Entire page preview should be clickable to follow up on this.


Thanks for your comments, lets see what product and design think about the other ones!

I'm tagging the backlog to have some discussion here. Ping @ovasileva

I have one more suggestion:

  • If technically possible, disable temporarily the page previews while a text selection is going on. One use case for wikipedia is to copy and paste text (yes, I guess those school assignments are a use cases). When doing that, probably the user doesn't intend to get more information if it stops on a text. This is much more arguable, as it may be tuned with the delay to appear- so not 100% sure about it.
  • In the feature request side of things, maybe being able in the future to disable images could be considered. [] Enable page previews []enable page previews without images []disable page previews
Jdlrobson added a subscriber: Jdlrobson.

Could the feature be enabled at other projects on links towards wikipedias (e.g. Wikidata, but only for interwiki links, wikivoyage, but only for [[w: ]] links, etc.? That should be easier than making summaries work for other types of content (I am just guessing)?

I don't see any technical reasons why "intrawiki links" would not be possible, however I believe we would need to parse the href of every link on hover to determine which wiki it belongs to. However, this would require additional config and code complexity to disable the normal links case while the summary endpoint was missing.

Tagging design to get some of their thoughts.

alexhollender added a subscriber: alexhollender.

@ovasileva @Jdlrobson are y'all okay with closing this out? If so feel free to do so :)
I believe it has served its purpose, as individual tasks have been created to represent the various actionable items (T192773 and T192772)

Jdlrobson closed this task as Resolved.Sep 25 2018, 5:25 PM
Jdlrobson claimed this task.

The "gear" icon on the preview panel links to https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-rendering For me this is highly confusing, I think it should link to id #mw-prefsection-rendering-reading so the enable/disable preferences are on top.

Feels like this is being talked about in T192772

I am worried if people with limited mobility (disabilities, elder people, etc.) will have issues with it, and if it would be nice to allow optionally for a "slower" mode (where panel takes more time to disappear/mouse can be moved with even less precision).

Did we consider this as part of our accessibility drive?

predict a lot of people asking "why is my text/image not showing". Maybe that bit can be copied into the 'Help:' namespace on Wikipedia. I wonder also if Wikidata could be used to decide an image in case of conflict?

Documented in https://www.mediawiki.org/wiki/Extension:Popups#FAQ

Could the feature be enabled at other projects on links towards wikipedias

Yes. wikidata is tracked in T199096 and hopefully Wikivoyage will be enabling it soon (T203981)

I feel the area that is clickable on the panel is strange

tracked in T192773

So yes, it feels like we covered all of @jcrespo 's feedback.
@jcrespo if you don't feel satisfied with the discussion here please feel free to reopen with any questions! Thank you!

jcrespo added a comment.EditedSep 26 2018, 8:49 AM

There is only one misunderstanding, I didn't request to generate previews of Wikidata or Wikioyage projects as those task propose (I think that is secondary and more difficult), but to enable ir (or allow enabling it) for Wikipedia links on non-Wikipedias (internal wp:en: / :en links, for example). E.g. Wikivoyage and Wikidata and wiktionary may have a lot of Wikipedia links. E.g., on https://www.wikidata.org/wiki/Q2, the interwikis could show the Wikipedia previews.

Those are already supported on the backends and the data (previous) is already stored, so in theory (of course, I don't really know for sure) it should be simpler. CC Services

There is only one misunderstanding, I didn't request to generate previews of Wikidata or Wikioyage projects as those task propose (I think that is secondary and more difficult), but to enable ir (or allow enabling it) for Wikipedia links on non-Wikipedias (internal wp:en: / :en links, for example). E.g. Wikivoyage and Wikidata and wiktionary may have a lot of Wikipedia links. E.g., on https://www.wikidata.org/wiki/Q2, the interwikis could show the Wikipedia previews.

I believe this is tracked in T67117